【pta甲级】1009. Product of Polynomials (25)

在这里插入图片描述
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6

还是用map做的,还是做复杂了,用普通的数组直接做就挺好的
用map反而不好处理细节

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    int m;
    map<int ,double>a;
    map<int,double>b;
    map<int,double,greater<int>>c;
    cin>>n;
    int t;
    double tt;
    for(int i=0;i<n;i++){
        cin>>t;
        cin>>tt;
        a[t]=tt;
    }
    cin>>m;
    for(int i=0;i<m;i++){
        cin>>t;
        cin>>tt;
        b[t]=tt;
    }
    for(auto x:a){
        for(auto y:b){
            t=x.first+y.first;
            tt=x.second*y.second;
            if(tt!=0)
                c[t]+=tt;

        }
    }
    
    for(auto x:c){
        // cout<<x.first<<' '<<x.second;
        if(x.second==0)
            c.erase(x.first);
        // printf(" %d %.1f",x.first,x.second);
    }
	 cout<<c.size();
     for(auto x:c){
        // cout<<x.first<<' '<<x.second;
        if(x.second==0)
            c.erase(x.first);
        printf(" %d %.1f",x.first,x.second);
    }

    return 0;
}

还是附上大神的代码吧
https://blog.csdn.net/liuchuo/article/details/52109341

#include <iostream>
using namespace std;
int main() {
    int n1, n2, a, cnt = 0;
    scanf("%d", &n1);
    double b, arr[1001] = {0.0}, ans[2001] = {0.0};
    for(int i = 0; i < n1; i++) {
        scanf("%d %lf", &a, &b);
        arr[a] = b;
    }
    scanf("%d", &n2);
    for(int i = 0; i < n2; i++) {
        scanf("%d %lf", &a, &b);
        for(int j = 0; j < 1001; j++)
                ans[j + a] += arr[j] * b;
    }
    for(int i = 2000; i >= 0; i--)
        if(ans[i] != 0.0) cnt++;
    printf("%d", cnt);
    for(int i = 2000; i >= 0; i--)
        if(ans[i] != 0.0)
            printf(" %d %.1f", i, ans[i]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值