【问题描述】
蛇形填数
在n×n方阵里填入1,2,…,n×n,要求填成蛇形。例如,n=4时方阵为:
1 2 3 4
12 13 14 5
11 16 15 6
10 9 8 7
为了美化效果,我们设置每个数宽度为4,填充符号为*。先输入n值,n≤10。
【样例输入】
4
【样例输出】
***1***2***3***4
**12**13**14***5
**11**16**15***6
**10***9***8***7
#include <iostream>
#include <iomanip>
#define X 10
using namespace std;
int main()
{
int s = 1; // 数
int r = 0; // 行
int c = 0; // 列
int a[X][X] = {0};
a[r][c] = s; // 初始天数
int n; // 填充大小
cin >> n;
while (s < n * n)
{
while (a[r][c + 1] == 0 && c + 1 <= n - 1)
{
a[r][++c] = ++s;
}
while (a[r + 1][c] == 0 && r + 1 <= n - 1)
{
a[++r][c] = ++s;
}
while (a[r][c - 1] == 0 && c - 1 >= 0)
{
a[r][--c] = ++s;
}
while (a[r - 1][c] == 0 && r - 1 >= 0)
{
a[--r][c] = ++s;
}
}
for (int i = 0; i < n; i++)
{
for (int j = 0; j < n; j++)
{
cout << setfill('*') << setw(4) << a[i][j];
}
cout << endl;
}
return 0;
}