Registration system (南阳理工oj 题目991)

题目链接  http://acm.nyist.net/JudgeOnline/problem.php?pid=991

Registration system

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述

A new e-mail service "Berlandesk" is going to be opened in Berland in the near future.

 The site administration wants to launch their project as soon as possible, that's why they

 ask you to help. You're suggested to implement the prototype of site registration system. 

The system should work on the following principle.

Each time a new user wants to register, he sends to the system a request with his name.

 If such a name does not exist in the system database, it is inserted into the database, and 

the user gets the response OK, confirming the successful registration. If the name already 

exists in the system database, the system makes up a new user name, sends it to the user 

as a prompt and also inserts the prompt into the database. The new name is formed by the

 following rule. Numbers, starting with 1, are appended one after another to name (name1,

 name2, ...), among these numbers the least i is found so that namei does not yet exist in

 the database.


输入
The first line contains number n (1 ≤ n ≤ 105). The following n lines contain the requests to the system. Each request is a non-empty line, and consists of not more than 1000 characters, which are all lowercase Latin letters.
输出
Print n lines, which are system responses to the requests: OK in case of successful registration, or a prompt with a new name, if the requested name is already taken.
样例输入
4
abacaba
acaba
abacaba
acab
样例输出
OK
OK
abacaba1
OK
题目大意:

就按照测试数据说吧,这样好理解。第一行输入4表示将要向系统输入4个名字(这四个人需要注册,但是注册时的名字不能相同),系统会根据你输入的顺序进行判断(如果这个人的名字没有出现过,那么输出“OK”;如果这个人的名字出现过,那么若是第一次重复出现,输出“名字1”,第二次重复出现,输出“名字2”......)。

解题思路:

这道题是STL中map容器的应用。

代码:

#include<iostream>
#include<map>   //map容器需要用到的头文件
using namespace std;
int main()
{
    int n;
    string s;
    map<string,int>M;   //定义一个 字符串类型——整型 map容器M
    cin>>n;
    while(n--)
    {
        cin>>s;
        M[s]++;   //该名字的个数+1
        if(M[s]==1)   //如果该名字的个数为1,说明是第一次出现,所以输出“OK”
            cout<<"OK"<<endl;
        else
            cout<<s<<M[s]-1<<endl;   //否则的话,说明已经出现过,“输出名字”+“出现的个数-1”
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值