POJ 2488A Knight's Journey9(DFS)

Language:

A Knight's Journey

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 42414 Accepted: 14423

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意:王子的在p*q的矩阵里的运动轨迹,王子的运动方式类似于象棋里的“马走日”。并且按照优先字典序的方式进行移动。

题解:简单的dfs,定义一个Map二维数组用来储存王子可以移动的八种方式,xx和yy数组用来储存每一步移动的地址(这是关键的一步)。

注意:ABC...是列,123...是行,所以注意输入。



#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;

int p, q, num, flag ;
char Map[8][2] = {{-2, -1}, {-2, 1}, {-1, -2}, {-1, 2}, {1, -2}, {1, 2}, {2, -1}, {2, 1}};
int xx[30], yy[30];
int div[30][30];
void dfs(int x, int y, int num)
{
  int i, j, xi, yi;
  xx[num] = x;
  yy[num] = y;
  if(num == p * q)
    {
      flag = 1;
      return ;
    }
  for(i = 0; i < 8; i++)
    {
      xi = x + Map[i][0];
      yi = y + Map[i][1];
      if(xi >= 1 && xi  <= p && yi >= 1 && yi <= q&&div[xi][yi] == 0 && flag == 0)
        {
              div[xi][yi] = 1;
              dfs(xi, yi, num + 1);
              div[xi][yi] = 0;
        }
    }
}
int main()
{
  int i, j;
  int n;
  int cesa = 0;
  cin>>n;
  while(n--)
    {
      cesa++;
      cin>>q>> p;
      flag = 0;
      memset(div, 0 ,sizeof(div));
      div[1][1] = 1;
      dfs(1,1,1);
      cout<<"Scenario #"<<cesa<<":"<<endl;
      if(flag == 1)
        {
          for(i = 1; i <= p * q; i++)
            {
              printf("%c%d",xx[i]+'A'-1,yy[i]);
            }
          cout<<endl<<endl;
        }
      else
        {
          cout<<"impossible"<<endl<<endl;
        }
    }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值