POJ 1201Intervals(差分约束系统)

Intervals

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 26260 Accepted: 10048

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.
Write a program that:
reads the number of intervals, their end points and integers c1, ..., cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

题意:

给定一个n,然后给定n个区间和n个数,在区间任意取一些数构成一个集合,

要求每个区间和元素集合V的交集至少有两个不同的元素,

求集合V最小的元素个数。


解题思路:

约束差分,首先找到符合题意得不等式,即a[i] - a[i+1] >= -1, a[i+1] - a[i] >= 0, b - a >= c;用向前星的构图,进行spfa的最短路的权值变换。(SPFA的详细讲解)

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <queue>
#include <vector>
#include <map>

using namespace std;

const int inf = 0x3f3f3f3f;
const int Max = 50500;
typedef long long int LL;

struct node
{
    int w;
    int to;
    int next;
}s[3*Max];
int head1[Max];
int vis[Max];
int minn, maxx, n;
int cut;

void init()
{
    maxx = 0;
    minn = inf;
    cut = 0;
    memset(head1, -1, sizeof(head1));
    memset(vis, 0, sizeof(vis));
}

void spfa()
{
    int i;
    int dis[Max];
    for(i = minn; i <= maxx; i++)
    {
        dis[i] = -inf;
    }
    dis[minn] = 0;
    queue <int> q;
    q.push(minn);
    while(!q.empty())
    {
        int e = q.front();
        q.pop();
        vis[e] = 0;
        for(i = head1[e]; i != -1; i = s[i].next)
        {
            if(dis[s[i].to] < dis[e] + s[i].w)
            {
                dis[s[i].to] = dis[e] + s[i].w;
                if(!vis[s[i].to])
                {
                    q.push(s[i].to);
                    vis[s[i].to] = 1;
                }
            }
        }
    }
    printf("%d\n", dis[maxx]);
}

int main()
{
    int u, v, w, i;
    scanf("%d", &n);
    init();
    for ( i = 0; i < n; ++i)
    {
        scanf("%d %d %d" , &u, &v, &w);
        s[cut].to = v+1;
        s[cut].w = w;
        s[cut].next = head1[u];
        head1[u]  = cut++;
        maxx = max(maxx, v+1);
        minn = min(minn, u);
    }
    for(i = minn; i < maxx; i++)
    {
        s[cut].to = i+1;
        s[cut].w = 0;
        s[cut].next = head1[i];
        head1[i] = cut++;
        s[cut].to = i ;
        s[cut].w = -1;
        s[cut].next = head1[i+1];
        head1[i+1] = cut++;
    }
    spfa();
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值