已知后序和中序求层序

1020. Tree Traversals (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#define inf 0x3f3f3f3f

using namespace std;

int s[135], l[135];
int ans[135];
typedef int element;
typedef struct node
{
    element data;
    node *lchild, *rchild;
}node, *Tree;


Tree creat(int sl, int sr, int ll, int lr)
{
    if(sr-sl <0)
        return NULL;
    Tree T;
    T = new node;
    T->data = s[sr];
    int p=ll;
    while(l[p] != s[sr])
        ++p;
    int t = lr - p;
    T->lchild = creat(sl, sr-t-1, ll, p-1);
    T->rchild = creat(sr-t, sr-1, p+1, lr);
    return T;
}
void posd(Tree T)
{
    if(T)
    {
        printf("%d ", T->data);
        posd(T->lchild);
        posd(T->rchild);
    }
}

void level(Tree T)
{
    int out = 0;
    int in = 0;
    Tree p[150];
    p[in++] = T;
    int j = 0;
    while(in > out)
    {
        if(p[out])
        {
            ans[j++] = p[out]->data;
            p[in++] = p[out]->lchild;
            p[in++] = p[out]->rchild;
        }
        out++;
    }
}

int main()
{
    int n, m, k;
    int i, j;
    cin>>n;
    Tree L;
    for(i = 0; i < n; i++)
    {
        scanf("%d", &s[i]);
    }
    for(i = 0; i < n; i++)
    {
        scanf("%d", &l[i]);
    }
    L = creat(0,n-1,0,n-1);
    posd(L);
    /*level(L);
    for(i = 0; i < n-1; i++)
    {
        printf("%d ",ans[i]);
    }
    printf("%d\n", ans[n-1]);*/
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值