ZOJ1002所有测试数据正确,无法AC,请给反例

本文介绍了一种算法,用于在一个受限地图中确定可以放置的最大合法火砦数量,考虑了子弹的运行路径和城市街道的限制。通过实例演示和代码实现,探讨了如何在4x4城市中找到最优火砦配置,适用于城市规划和防御问题。
摘要由CSDN通过智能技术生成

fire Net
Time Limit: 2 Seconds      Memory Limit: 65536 KB
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.


Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0
Sample output:

5
1
5
2
4

def listplusone(l,n):   #数据列表自增函数(用于生成搜索下标)
    i=len(l)-1
    l[i] = l[i] + 1
    while i>=0:
        if l[i]==n:
            l[i]=0
            if i!=0:
                l[i-1]+=1
        i-=1
    return l

def legalTest(l):         #合法性检测函数
    t = ''
    for i in l:
        if t == '0':
            if t == i:
                return 0
            if i == 'X':
                t = ''
        if i == '0':
            t = i
    return 1
try:
    maxlist=[]         #最大数列表
    while True:
        l = []  # 输入的城市
        n = int(input())
        if n == 0:
            break
        for i in range(n):
            inp = input()
            l.append(inp[:n])
        legalcomb = []    #二维列表,每一行存放所有合法的组合
        #print(l)
        for i in range(n):
            legalcomb.append([])
            for j in range(2):#每一行最多放2个blockhouses,找出所有合法的组合放入列表中
                temp=[]
                if j==0:  #只放一个blockhouses
                    for k in range(n):
                        temp = list(l[i])  # 临时列表
                        if temp[k]=='.':
                            temp[k]='0'
                        if legalTest(temp):
                            legalcomb[i].append(temp)
                if j==1: #放两个blockhousess
                    for k in range(n):
                        for q in range(k+1,n):
                            temp = list(l[i])  # 临时列表
                            if temp[k]=='.' and temp[q]=='.':
                                temp[k]='0'
                                temp[q]='0'
                            if legalTest(temp):
                                legalcomb[i].append(temp)
        mx=0          #找出legalcomb中每行中最大个数的组合
        for i in range(n):
            if mx<len(legalcomb[i]):
                mx=len(legalcomb[i])
        for i in range(n):
            if len(legalcomb[i])<mx:
                for j in range(len(legalcomb[i]),mx):
                    legalcomb[i].append(['+']*n)    #仅占位
        #横轴所有合规
        # for i in range(n):
        #     print(legalcomb[i])
        #开始检验纵轴合规
        l_temp=[]               #存放纵轴每种可能的下标
        temp=[]                 #存放纵轴合规的组合
        #os.system("pause")
        for i in range(n):     #初始化搜索序列
            l_temp.append(0)
        legalend=[]          #存放横轴纵轴都合规的组合
        #print(l_temp)
        while True:
            temp = []
            for i in range(n):
                temp.append(legalcomb[i][l_temp[i]])         #按照l_temp进行测试
                #print("temp%d=" % i, end="")
                #print(temp[i])
            #os.system("pause")
            l_temp = listplusone(l_temp, len(legalcomb[0]))  #下一个搜索
            if sum(l_temp)==0:                               #搜索完毕退出
                break
            if ['+', '+', '+', '+'] in temp:                #占位的不进行后续测试
                continue
            #print(l_temp)
            #print(temp)
            temp2=[]
            b=True        #合规标志
            for i in range(n):
                for j in range(n):
                    temp2.append(temp[j][i])
                if legalTest(temp2)==0:
                    b=False
                    break
                temp2=[]
            if b:
                legalend.append(temp)   #检验temp中的布局是否满足条件

        mx=0
        m=0

        for i in legalend:             #所有满足条件的布局找出最多炮塔值
            for j in range(len(i)):
                if '0' in i[j]:
                    m+=str(i[j]).count('0')
            if mx<m:
                mx=m
            m=0
        # for i in legalend:
        #     for j in i:
        #         print(j)
        #     print("---------------")
        maxlist.append(mx)
    for i in maxlist:
        print(i)
except ValueError:
    pass
except IndexError:
    pass


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值