ZCMU—1051

1051: Divide Chocolate

Time Limit: 1 Sec   Memory Limit: 128 MB
[ Submit][ Status][ Web Board]

Description

It is well known that Claire likes dessert very much, especially chocolate. But as a girl she also focuses on the intake of calories each day. To satisfy both of the two desires, Claire makes a decision that each chocolate should be divided into several parts, and each time she will enjoy only one part of the chocolate. Obviously clever Claire can easily accomplish the division, but she is curious about how many ways there are to divide the chocolate.

To simplify this problem, the chocolate can be seen as a rectangular contains n*2 grids (see above). And for a legal division plan, each part contains one or more grids that are connected. We say two grids are connected only if they share an edge with each other or they are both connected with a third grid that belongs to the same part. And please note, because of the amazing craft, each grid is different with others, so symmetrical division methods should be seen as different.

Input

  First line of the input contains one integer indicates the number of test cases. For each case, there is a single line containing two integers n (1<=n<=1000) and k (1<=k<=2*n).n denotes the size of the chocolate and k denotes the number of parts Claire wants to divide it into.

Output

For each case please print the answer (the number of different ways to divide the chocolate) module 100000007 in a single line. 

Sample Input

2
2 1
5 2

Sample Output

1
4 5

【分析】

题意很简单,给你2*n的巧克力,让你分成m份,问有几种方案。
显然是个状态dp...而且很容易想到跟骨牌覆盖一样的dp,但是没有骨牌覆盖那么简单,因为骨牌覆盖固定了骨牌的模式,而这道题没有规定如何切....虽然状态转移比骨牌覆盖少。。。但是的确我一直处于算错状态

f[i][0][j]表示前i行已经出现了j份并且第i行的两格属于同一部分
f[i][1][j]表示前i行已经出现了j份并且第i行的两格不属于同一部分也就是被切开
状态转移有12个情况
f[i+1][0][j]=(f[i+1][0][j]+f[i][0][j]+f[i][1][j]*2)%mod;  
f[i+1][0][j+1]=(f[i+1][0][j+1]+f[i][0][j]+f[i][1][j])%mod;  
f[i+1][1][j]=(f[i+1][1][j]+f[i][1][j])%mod;  
f[i+1][1][j+1]=(f[i+1][1][j+1]+f[i][0][j]*2+f[i][1][j]*2)%mod;  
f[i+1][1][j+2]=(f[i+1][1][j+2]+f[i][0][j]+f[i][1][j])%mod;  

初始化 f[1][1][2]= f[1][0][1]=1;  
很难的一题DP...嗯...至少对我来说比较难了
【代码】
#include <stdio.h>
#define mod 100000007  
int f[1010][2][2020]={0};  
int main()  
{   
    f[1][1][2]=1;  
    f[1][0][1]=1;  
    for(int i=1;i<=1000;i++)  
    {  
        for(int j=1;j<=2*i;j++)  
        {  
        	f[i+1][0][j]=(f[i+1][0][j]+f[i][0][j]+f[i][1][j]*2)%mod;  
        	f[i+1][0][j+1]=(f[i+1][0][j+1]+f[i][0][j]+f[i][1][j])%mod;  
        	f[i+1][1][j]=(f[i+1][1][j]+f[i][1][j])%mod;  
        	f[i+1][1][j+1]=(f[i+1][1][j+1]+f[i][0][j]*2+f[i][1][j]*2)%mod;  
         	f[i+1][1][j+2]=(f[i+1][1][j+2]+f[i][0][j]+f[i][1][j])%mod;  
        }  
    }  
  	int pp;scanf("%d",&pp);
	while(pp--)  
  	{  
    	int n,m;scanf("%d%d",&n,&m);  
    	printf("%d\n",(f[n][1][m]+f[n][0][m])%mod);    
  	}  
  return 0;  
}  


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值