ZCMU—1149

1149: Dividing coins

Time Limit: 1 Sec  Memory Limit: 128 MB
[Submit][Status][Web Board]

Description

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

Input

A line with the number of problems n, followed by n times:

  • a line with a non negative integer m (m<=100) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input

2
3
2 3 5
4
1 2 4 6

Sample Output

0
1

【分析】

题意:给你n个硬币,让你分成两堆,使得两堆的硬币总和之差最小...
唔...题目大概难在题目是英文了吧...显然对硬币总价值sum,能分出一堆sum/2的硬币就是最优解,所以对sum/2为容量的背包做一次01背包就可以了,每个硬币的价值和体积都是a[i],背包大小为sum/2,求出最大的那个解,另外一堆的价值就是sum-f[sum/2],差值就是sum-2*f[sum/2]
状态转移方程就是最基本的f[j]=max(f[j],f[j-a[i]]+a[i]);
【代码】
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int a[1000];
int f[60000];
int main()
{
	int pp;scanf("%d",&pp);
	while (pp--)
	{
		memset(f,0,sizeof(f));
		int n;scanf("%d",&n);
		int sum=0;
		int ans=-1;
		a[0]=0;
		for (int i=1;i<=n;i++) scanf("%d",&a[i]),sum+=a[i];
		for (int i=1;i<=n;i++)
			for (int j=sum/2;j>=a[i];j--)
					f[j]=max(f[j],f[j-a[i]]+a[i]);
		printf("%d\n",abs(sum-2*f[sum/2]));
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值