ZCMU—1052

1052: Holedox Eating

Time Limit: 1 Sec  Memory Limit: 128 MB
[Submit][Status][Web Board]

Description

Holedox is a small animal which can be considered as one point. It lives in a straight pipe whose length is L. Holedox can only move along the pipe. Cakes may appear anywhere in the pipe, from time to time. When Holedox wants to eat cakes, it always goes to the nearest one and eats it. If there are many pieces of cake in different directions Holedox can choose, Holedox will choose one in the direction which is the direction of its last movement. If there are no cakes present, Holedox just stays where it is.

Input

The input consists of several test cases. The first line of the input contains a single integer T (1 <= T <= 10), the number of test cases, followed by the input data for each test case.The first line of each case contains two integers L,n(1<=L,n<=100000), representing the length of the pipe, and the number of events.

The next n lines, each line describes an event. 0 x(0<=x<=L, x is a integer) represents a piece of cake appears in the x position; 1 represent Holedox wants to eat a cake.

In each case, Holedox always starts off at the position 0.

Output

Output the total distance Holedox will move. Holedox don’t need to return to the position 0.

Sample Input

3
10 8
1
0 5
1
0 2
0 0
1
1
1
 
10 7
0 1
0 5
1
0 2
0 0
1
1
10 8
0 1
0 1
0 5
1
0 2
0 0
1
1

Sample Output

Case 1: 9
Case 2: 4
Case 3: 2

【分析】

题意:在一条直线上,从0开始, 每次都是吃最近的点,每次只能吃一个,在哪个位置吃的,吃过之后就在那个位置上站着。没有饼,就站在原地,如果离左右最近的点距离一样,就按照原来走的方向。 
直接模拟...只是排序非常麻烦罢了...这里可以考虑stl中的<set>因为元素可能重复,所以要用multiset
不过感觉这个方法不是出题者希望的解题方法吧..感觉应该要用线段树..不过set复杂度没问题所以直接敲了set
【代码】
#include <iostream>
#include <algorithm>
#include <set>
#include <cstdio>
#define INF 0x7ffffff
using namespace std;  
int main()
{  
    int t;  
    long long sum;  
    int L,n;  
    int a,b;  
    long long m,p;  
    int pp;scanf("%d",&pp);  
    for(int p=1;p<=pp;p++)
	{  
        scanf("%d%d",&L,&n);  
        sum=0;  
        multiset<int>s;                        
        multiset<int>::iterator it,d;  
        int cur=0,pre=0;  
        while(n--)
		{  
             scanf("%d",&a);  
             if(a==0)
			 {  
                 scanf("%d",&b);  
                 s.insert(b);  
             }  
             else
			 {  
                  m=INF;  
                  if(s.empty()) continue;  
                  for(it=s.begin();it!=s.end();it++)
				  {  
                      if(abs(*it-cur)<m)
					  {     
                          m=abs((*it)-cur);  
                          d=it;              
                      }  
                      else 
					  if(abs(*it-cur)==m)
					  {    
                          if((*it-cur)*(cur-pre)>0)
						  {  
                              m=abs((*it)-cur);  
                              d=it;  
                          }  
                      }  
                  }
				  sum+=m;  
                  pre=cur;       
				  cur=*d;  
                  s.erase(d);  
                           
             }  
        }  
        printf("Case %d: %lld\n",p,sum);  
    }  
    return 0;  
}  


### 回答1: zcmu 1093 简单计算器是一道编程题目,要求实现一个简单的计算器,能够进行加、减、乘、除四种基本运算。该题目主要考察编程基础能力和算法思维能力,需要熟练掌握基本的运算符和控制语句,能够设计合理的算法实现计算器功能。 ### 回答2: zcmu 1093 简单计算器是一种基于计算机技术的工具,用于进行基本算术运算,如加减乘除等。它能够简化我们在日常生活中的计算工作,提高计算效率,减少出错率。 使用zcmu 1093 简单计算器非常简单,只需输入需要计算的数字和符号,就能够得到计算结果。它可以进行多个数字之间的复杂运算,同时还支持小数、百分数、平方根等复杂运算。另外,zcmu 1093 简单计算器还可以存储中间计算结果,方便我们进行多步计算或调整计算过程。 除了日常的计算工作,zcmu 1093 简单计算器还可用于科学计算、工程设计等领域。许多专业软件都是基于简单计算器原理设计的,它们具有更高的计算精度和更复杂的运算能力,能够支持更高级别的科学计算和技术分析。 总之,zcmu 1093 简单计算器在日常生活中有着广泛的应用,它使我们的计算工作变得更加高效、准确。并且,随着科技的不断发展,这种计算工具也在不断地更新和改进,为我们的计算工作提供更加便捷、多样化的选择。 ### 回答3: ZCMU 1093 简单计算器是一道基础的算法题目,需要实现一个简单的计算器程序,支持加、减、乘、除四种基本运算,可以对两个整数进行运算并输出结果。 要实现这道题目,首先需要根据输入的运算符来判断应该进行的运算类型,并根据运算符的不同,执行不同的计算操作。同时,应注意除数不能为零的情况,避免程序出现异常。 在编写程序的过程中,可以使用 switch case 语句来判断不同的运算类型,并执行相应的计算操作。同时,为了能有效地判断输入的运算符,可以使用输入字符串的方式进行处理,提取出运算符进行比较。 此外,在程序中还需要进行合法性判断,确保输入的数字均为整数且在合理的范围内,以避免程序运行出现异常情况。同时,还需要考虑输入格式的问题,应确保输入的数字和运算符符合题目要求。 综上所述,ZCMU 1093 简单计算器是一道基础的算法题目,需要实现一个简单的计算器程序,支持加、减、乘、除四种基本运算,注意程序的合法性判断和输入格式的处理,能够熟练地运用 switch case 等语句完成程序的编写。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值