hdu—4576

Robot

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 5069    Accepted Submission(s): 1494


Problem Description
Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise.



At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.
Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).
Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.  
The input end with n=0,m=0,l=0,r=0. You should not process this test case.
 

Output
For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.
 

Sample Input
  
  
3 1 1 2 1 5 2 4 4 1 2 0 0 0 0
 

Sample Output
  
  
0.5000 0.2500
 

Source
 

【分析
题意:有一个机器人,每个命令是走m步,可以向前可以向后,问最后停在[l,r]之间的概率
数据挺小的...模拟或者概率dp都可以..我这里直接写了一个简单dp...因为数据挺小的直接去dp模拟状态了
对于f[i][j],i表示状态,j表示点。直接模拟就可以了
【代码】
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std; 
int main()
{
    int n,m,l,r;
    double f[2][210];
    while(~scanf("%d%d%d%d",&n,&m,&l,&r))
    {
        if(n==0&&m==0&&l==0&&r==0)break;
        memset(f,0,sizeof(f));
        f[0][1]=1;
        int temp1,temp2,temp;
    	temp=0;
        for(int i=1;i<=m;i++)
        {
            int w;scanf("%d",&w);
            for(int j=1;j<=n;j++)
            {
                temp1=j+w;if (temp1>n) temp1-=n;
                temp2=j-w;if (temp2<1) temp2+=n;
                f[(temp+1)%2][temp1]+=f[temp][j]*0.5;
                f[(temp+1)%2][temp2]+=f[temp][j]*0.5;
                f[temp][j]=0;   
            }
            temp=(temp+1)%2;
        }
        double ans=0;
        for(int i=l;i<=r;i++) ans+=f[temp][i];
        printf("%.4f\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值