ZCMU—1866

1866: Problem C - Sumsets

Time Limit: 1 Sec   Memory Limit: 128 MB
[ Submit][ Status][ Web Board]

Description

Problem C - Sumsets

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.

Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.

Output

For each S, a single line containing d, or a single line containing "no solution".

Sample Input

5
2 3 5 7 12
5
2 16 64 256 1024
0

Sample Output

12
no solution

【分析】

经典的a+b+c=d的题目...因为数据有点水所以貌似O(n^3)也过了..
排序就不说了...也没人不会排序..
然后折半枚举的思路,把a+b+c=d变形成a+b=d-c就可以把这道题的复杂度降低,然后就是判重的问题了,因为如果分开处理a+b和d-c的话需要防止a+b=d-b这种情况的出现,也就是说要保证a,b,c,d四个数不重复,所以需要记录一下位置..当然n^3的算法不需要记录...
对每个d-c,有两种方法去找a+b,一种是记录位置之后,先判重,然后二分查找直接找到那个d-c是否存在于a+b的集合中,找到的第一个d就是答案。
或者用二分的思想去写for循环,速度慢一些,但是可以让你的思路考虑更加简单,因为不需要考虑位置了...我们写代码是为了什么~不就是为了把自己想很麻烦的事交给电脑去做么...
【代码】
#include <stdio.h>
#include <algorithm> 
using namespace std;
 
int a[1100];
int x,y,n,m,len,pos,t,tt;
 
int main()
{
    while (~scanf("%d",&n)&& n)
    {
        for (int i=0;i<n;i++) scanf("%d",&a[i]);
        sort(a,a+n);
        for (int i=n-1;i>=0;i--)
            for (int j=n-1;j>=0;j--)
                if (i!=j)
                {
                    t=a[i]-a[j];
                    x=0;y=j-1;
                    while (x<y) 
                    {
                        if (a[x]+a[y]==t)
                        {
                            printf("%d\n",a[i]);
                            goto out;
                        }
                        if (a[x]+a[y]<t)
                            x++;
                        else
                            y--;
                    }
                }
        printf("no solution\n");
        out:;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值