POJ—1426

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32261 Accepted: 13470 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

【分析】

比较简单的一道搜索题...*10和*10+1两种情况,long long能吃的下最终情况..所以直接搜索就可以了

不过这里有一种,非常简洁的方式,因为只有两种情况*10或者*10+1,非常像二叉树,所以这里可以用哈夫曼思想,直接在数组中模拟搜索

【代码】

#include<iostream>  
#include<stdio.h>  
#include<string.h>  
#include<queue>  
using namespace std;  
  
long long f[1000000];  
  
int main()  
{  
    int n;f[0]=0;
    while(~scanf("%d",&n)&&n)  
    {  
        int i;  
        for(i=1;;i++)  
        {  
            f[i]=f[i/2]*10+i%2;  
            if(f[i]%n==0) break;  
        }  
        printf("%lld\n",f[i]);  
    }  
    return 0;  
}  
dfs

#include <stdio.h>
int n;
long long ans=-1;
void dfs(long long now,int deep)
{
	if (ans!=-1) return;
	if (deep>19) return;
	if (now%n==0)
	{
		ans=now;return;
	}
	
	dfs(now*10,deep+1);
	if (ans!=-1) return;
	dfs(now*10+1,deep+1);
}

int main()
{
	while (~scanf("%d",&n)&&n)
	{
		ans=-1;
		dfs(1,1);
		printf("%lld\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值