POJ ACM习题【No.2656】

Unhappy Jinjin
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5571 Accepted: 4133

Description

Jinjin is a junior school student. Besides the classes in school, Jinjin's mother also arranges some supplementary classes for her. However, if Jinjin studies for more than eight hours a day, she will be unhappy on that day. On any day she gets unhappy, the more time she studies, the unhappier she will be. Now we got Jinjin's class schedule for the next several days and your task is to find out whether she will be unhappy on these days; if she will be unhappy, on which day she will be the unhappiest.

Input

There may be several test cases. In the first line of each test case, there is an integer N (1 <= N <= 7), which represents the number of days you should analyze. Then there comes N lines, each contains two non-negative integers (each smaller than 10). The first integer represents how many hours Jinjin studies at school on the day, and the second represents how many hours she studies in the supplementary classes on the same day.

A case with N = 0 indicates the end of the input, and this case should not be processed.

Output

For each test case, output a line contains a single integer. If Jinjin will always be happy, the integer should be 0; otherwise, the integer should be a positive integer K, which means that Jinjin will be the unhappiest on the K-th day. If the unhappiest day is not unique, just output the earliest one among these unhappiest days.

Sample Input

7
5 3
6 2
7 2
5 3
5 4
0 4
0 6
1
4 4
0

Sample Output

3
0

 

此题很简单,直接贴代码:

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		int caseNum = 0;
		int unhappyDay, unhappyValue;
		int studyTime = 0;
		
		while(true)
		{
			unhappyDay = 0;
			unhappyValue = 0;
			caseNum = cin.nextInt();
		
			if(caseNum == 0)
				break;
			else
			{
				int[][] time = new int[caseNum][2];
				for(int i = 0; i < caseNum; i++)
				{	
					for(int j = 0; j < 2; j++)
						time[i][j] = cin.nextInt();
					
					studyTime = time[i][0] + time[i][1];
					if(studyTime > 8)
					{
						if(studyTime > unhappyValue)
						{
							unhappyValue = studyTime;
							unhappyDay = i + 1;
						}
					}

				}
				System.out.println(unhappyDay);	
			}
		}
	}
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值