POJ ACM习题【No.2328】

Guessing Game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8323 Accepted: 2842

Description

Stan and Ollie are playing a guessing game. Stan thinks of a number between 1 and 10 and Ollie guesses what the number might be. After each guess, Stan indicates whether Ollie's guess is too high, too low, or right on.
After playing several rounds, Ollie has become suspicious that Stan cheats; that is, that he changes the number between Ollie's guesses. To prepare his case against Stan, Ollie has recorded a transcript of several games. You are to determine whether or not each transcript proves that Stan is cheating.

Input

Standard input consists of several transcripts. Each transcript consists of a number of paired guesses and responses. A guess is a line containing single integer between 1 and 10, and a response is a line containing "too high", "too low", or "right on". Each game ends with "right on". A line containing 0 follows the last transcript.

Output

For each game, output a line "Stan is dishonest" if Stan's responses are inconsistent with the final guess and response. Otherwise, print "Stan may be honest".

Sample Input

10
too high
3
too low
4
too high
2
right on
5
too low
7
too high
6
right on
0

Sample Output

Stan is dishonest
Stan may be honest

Source

 

解题源码:

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		
		Scanner cin = new Scanner(System.in);
	
		List guess = new ArrayList();
		List response = new ArrayList();
		
		while(cin.hasNext())
		{
			String guessNum = cin.nextLine();
			if(guessNum.equals("0"))
				break;
			String result = cin.nextLine();
			
			guess.add(guessNum);
			response.add(result);
			
			if(!result.equals("right on"))
				continue;
			
			else
			{
				int honest = check(guess, response);
				if(honest == 1)
					System.out.println("Stan may be honest");
				else
					System.out.println("Stan is dishonest");
				guess.clear();
				response.clear();
			}
		}
	}
	
	private static int check(List guess, List response)
	{
		int honest = 1;
		
		int lower = 0;
		int upper = 11;
		
		for(int i = 0; i < guess.size(); i++)
		{
			int g = Integer.valueOf((String)guess.get(i)).intValue();
			String r = (String)response.get(i);
			
			if(r.equals("too high"))
			{
				if(g <= lower)
				{
					honest = -1;
					break;
				}
				if(g < upper)
				{
					upper = g;
				}
				
			}
			if(r.equals("too low"))
			{
				if(g >= upper)
				{
					honest = -2;
					break;
				}
				if(g > lower)
				{
					lower = g;
				}
			}
			
			if(r.equals("right on"))
			{
				if(upper <= g || lower >= g || upper < lower)
				{
					honest = -3;
					break;
				}
			}
		}
		
		return honest;
	}

}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值