POJ ACM习题【No.2105】

IP Address
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9504 Accepted: 5433

Description

Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:
27
   26
  25
  24
  23
   22
  21
  20
 

128 64  32  16  8   4   2   1 

Input

The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.

Output

The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.

Sample Input

4
00000000000000000000000000000000 
00000011100000001111111111111111 
11001011100001001110010110000000 
01010000000100000000000000000001 

Sample Output

0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1

 

此题很简单,简单转换一下二进制数字,然后用StringBuffer连接起来即可

 

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		int num = Integer.valueOf(cin.nextLine()).intValue();


		
		for(int i = 0; i < num; i++)
		{
			String str, temp;
			int a,b,c,d = 0;
			StringBuffer sb = new StringBuffer();
			
			str = cin.nextLine();
			temp = str.substring(0, 8);
			sb.append(convert(temp));
			sb.append('.');
			temp = str.substring(8, 16);
			sb.append(convert(temp));
			sb.append('.');
			temp = str.substring(16, 24);
			sb.append(convert(temp));
			sb.append('.');
			temp = str.substring(24);
			sb.append(convert(temp));

			System.out.println(sb.toString());
		}

	}
	
	private static int convert(String str)
	{
		int value = 0;
		if(str.charAt(0) == '1')
			value += 128;
		if(str.charAt(1) == '1')
			value += 64;
		if(str.charAt(2) == '1')
			value += 32;
		if(str.charAt(3) == '1')
			value += 16;
		if(str.charAt(4) == '1')
			value += 8;
		if(str.charAt(5) == '1')
			value += 4;
		if(str.charAt(6) == '1')
			value += 2;
		if(str.charAt(7) == '1')
			value += 1;
		
		return value;
	}

}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值