POJ ACM习题【No.1007】

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33807 Accepted: 13022

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

 

实现Java的Comparator接口即可

 

 

import java.util.*;

class DNA
{
	private String str = null;
	private int sortNum = 0;
	
	public DNA(String input)
	{
		str = input;
		
		int num = 0;
		for(int i = 0; i < str.length()-1; i++)
		{
			for(int j = i+1; j < str.length(); j++)
				if(str.charAt(i) > str.charAt(j))
					num++;
		}
		sortNum = num;
	}
	
	public int getSortNum()
	{
		return sortNum;
	}
	
	public String toString()
	{
		return str;
	}
}

class DNAComparator implements Comparator
{
	public int compare(Object o1, Object o2)
	{
		DNA d1 = (DNA)o1;
		DNA d2 = (DNA)o2;
		
		if(d1.getSortNum() > d2.getSortNum())
			return 1;
		else if(d1.getSortNum() == d2.getSortNum())
			return 0;
		else
			return -1;
	}
}

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		String[] str = cin.nextLine().split(" ");
		
		int col = Integer.valueOf(str[0]).intValue();
		int row = Integer.valueOf(str[1]).intValue();
		List list = new ArrayList();
		
		for(int i = 0; i < row; i++)
		{
			DNA dna = new DNA(cin.nextLine());
			list.add(dna);
		}
		
		Collections.sort(list, new DNAComparator());
		print(list);
	}
	
	private static void print(List list)
	{
		Iterator iter = list.iterator();
		while(iter.hasNext())
		{
			System.out.println(iter.next());
		}
	}

}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值