POJ ACM习题【No.2756】

Autumn is a Genius
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4878 Accepted: 971

Description

Jiajia and Wind have a very cute daughter called Autumn. She is so clever that she can do integer additions when she was just 2 years old! Since a lot of people suspect that Autumn may make mistakes, please write a program to prove that Autumn is a real genius.

Input

The first line contains a single integer T, the number of test cases. The following lines contain 2 integers A, B(A, B < 32768) each. The size of input will not exceed 50K.

Output

The output should contain T lines, each with a single integer, representing the corresponding sum.

Sample Input

1
1 2

Sample Output

3

Hint

There may be '+' before the non-negative number!

 

 

此题一定要注意+0的情况,BigInteger处理不了

 

 

import java.util.*;
import java.math.*;

public class Main {

	public static void main(String[] args) 
	{
		Scanner cin = new Scanner(System.in);
		int num = Integer.valueOf(cin.nextLine()).intValue();
		
		for(int i = 0; i < num; i++)
		{
			String[] str = cin.nextLine().split(" ");

			BigDecimal a = new BigDecimal(str[0]);
			BigDecimal b = new BigDecimal(str[1]);
			
			BigDecimal result = a.add(b);
			System.out.println(result.toPlainString());
		}

	}

}
 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值