POJ ACM习题【No.2521】

How much did the businessman lose
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5766 Accepted: 3968

Description

Businessmen, of course, can make much money. However, sometimes, they would lose money in trading. For example, Jame, a businessman, brought in some goods each cost him 40 yuan and he decided to sell at the price of 70 yuan. Then a customer came to buy one, gave Jame 100 yuan, and of course got back 30 yuan. You may said, "Jame earned 30 yuan." But unfortunately, Jame found the 100 yuan from the customer was fake. What a poor man! In this case Jame lost 70 yuan (40 (the goods price) + 30 (the money paid back to the customer)).

Now your task is to calculate how much Jame would lose in this kind of trade. Of course in this case, sometimes Jame may still earn.

Input

The input consists of several instances. Each instance contains four integers N, M, P and C, which are all in the range [0, 50000], separated by a single space.

N is the cost price of Jame good.
M is the sell price.
P is the total fake money the customer gave Jame.
C is how much Jame paid back to the customer.

Here N < M. And P may be less than M, as customer may pay with some fake money and some true money.

The input is terminated by a line containing 4 zeros.

Output

For one instance, output one line contains exactly one integer, which tells how much Jame lost in the trade. If Jame still earned, just output a negative integer, the absolute value of which tells the money Jame earned.

Sample Input

40 70 100 30
40 70 50 20
14604 32391 3902 153
0 0 0 0

Sample Output

70
20
-13885

 

利润

=真正收入-真正支出

=(总收入-假币)-(成本+找零)

=(标价+找零-假币)-(成本+找零)

 

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		while(cin.hasNext())
		{
			String tmp = cin.nextLine();
			if(tmp.equals("0 0 0 0"))
				break;
			String[] tmp1 = tmp.split(" ");
			int N = Integer.valueOf(tmp1[0]);
			int M = Integer.valueOf(tmp1[1]);
			int P = Integer.valueOf(tmp1[2]);
			int C = Integer.valueOf(tmp1[3]);
			
			int totalPaid = M + C;
			int totalTrue = totalPaid - P;
			
			int earn = totalTrue - N - C;
			
			System.out.println(earn*-1);
			
		}

	}

}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值