1010. Radix (25)-PAT甲级真题(详细注释)

该程序解决了一个数学问题,给定两个正整数N1和N2以及它们各自的进制,找到一个可能的进制使得转换后的数值相等。通过二分查找算法,确定能使等式成立的最小可能进制。如果找不到合适的进制,则输出Impossible。
摘要由CSDN通过智能技术生成

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

题解:

#include<bits/stdc++.h>
using namespace std;
string n1, n2;

long long convert(string n, long long radix)    //n为数,radix为进制,返回十进制数
{
    long long sum = 0;
    int index = 0, temp = 0;
    //rbegin()是转置之后的begin(), rend()同理
    for(auto it = n.rbegin(); it != n.rend(); it++)
    {
        temp = isdigit(*it) ? *it - '0' : *it - 'a' + 10;
        sum += temp * pow(radix, index++);
    }
    return sum;
}
//find_radix函数:找到令两个数值相等的进制数。在查找的过程中
//需要使用二分查找算法,如果使用当前进制转化得到数值比另一个大或者小于0,说明这个进制太大~
long long find_radix(string n, long long num)
{
    //取n中最大的一位字符it,使it+1为最小进制
    char it = *max_element(n.begin(), n.end());
    long long low = (isdigit(it) ? it - '0' : it - 'a' + 10) + 1;
    long long high = max(num, low);
    //二分法:
    while(low <= high)
    {
        long long mid = (low + high) / 2;
        long long t = convert(n, mid);
        if(t < 0 || t > num)    high = mid-1;   //为啥是mid-1?因为t严格>num
        else if(t == num)   return mid;             
        else    low = mid+1;                //因为t严格<num
    }
    return -1;
}

int main()
{
    long long tag = 0, radix = 0, result_radix;
    cin >> n1 >> n2 >> tag >> radix;
    
    if(tag == 1)
        result_radix = find_radix(n2, convert(n1, radix));
    else
        result_radix = find_radix(n1, convert(n2, radix));
    if(result_radix != -1)
        printf("%lld", result_radix);
    else
        printf("Impossible");
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值