甲级PAT 1013 Battle Over Cities(用cin始终最后一个测试运行超时来看)

1013 Battle Over Cities (25)(25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city~1~-city~2~ and city~1~-city~3~. Then if city~1~ is occupied by the enemy, we must have 1 highway repaired, that is the highway city~2~-city~3~.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (&lt1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

 题目要求

有N个城市,他们之间有M条路。当敌方入侵某一个城市时,与这座城市相邻的路都要封路,要保证其他的城市都能连通,至少需要修多少条路。判断对于输入的K个敌人入侵城市Ki(1《=Ki《=N),分布至少需要修多少条路

解题思路:

这是一道无向图的问题。用二维数组matrix存储城市之间的连接关系,这里不能之间通过每个城市的入度,然后对敌人入侵城市连接的入度全部减1,若入度为0则需要修路。因为这里可能会存在城市并非之前就全都相连的情况。所以要用DFS算法,一维数组visited表示城市是否已经遍历到。从城市1-N每次用DFS遍历一次,若还需遍历则遍历几次修几条路。

注意:

这里一定要用scanf输入而不是用cin输入。对于大量输入的操作,cin因为有同步机制所以会超时。这里有两种办法:

一、取消cin与stdin同步,在代码间添加ios::sync_with_stdio(false);即可

二、改用scanf输入

完整代码:

#include<iostream>
#include<cstring>
using namespace std;
#define maxsize 1001

int matrix[maxsize][maxsize];
int visited[maxsize];
int N,M,K;

int dfs(int v){
	int k;
	visited[v] = 1;
	for(k=1;k<=N;k++){
		if(visited[k] == 0&&matrix[k][v] == 1){
			dfs(k);
		}
	}
}

int main(){
//	ios::sync_with_stdio(false);
	int i,j,a,b,city,num;
	cin>>N>>M>>K;
	for(i=0;i<M;i++){
		scanf("%d %d",&a,&b);
	//	cin>>a>>b;
		matrix[a][b] = matrix[b][a] = 1;
	}
	for(i=0;i<K;i++){
		scanf("%d",&city);
	//	cin>>city;
		num = 0;
		memset(visited,0,sizeof(visited));
		visited[city] = 1;
		for(j=1;j<=N;j++){
			if(visited[j] == 0){
				dfs(j);
				num++;
			}
		}
		cout<<num-1<<endl;	
	}
	
	
	return 0;
} 

 

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值