质数打表(素数筛法)

    http://poj.org/problem?id=1595

 

1.开一个大的bool型数组prime[],大小就是n+1就可以了.先把所有的下标为奇数的标为true,下标为偶数的标为false.

    2.然后:

bool prim[maxn];
 for(i=3;i<=tmp;i++)  
{  
    if(prime[i])  
    {  
        for(j=i+i;j<=MAXN;j+=i)     prime[j]=false;  
    }  
}  
prime[1]=true;  
prime[2]=true;  

    3.最后输出bool数组中的值为true的单元的下标,就是所求的n以内的素数了。

    原理很简单,就是当i是质()数的时候,i的所有的倍数必然是合数。如果i已经被判断不是质数了,那么再找到i后面的质数来把这个质

数的倍数筛掉。

 


Description

A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.

Input

Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd.

Output

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.

Sample Input

21 2
18 2
18 18
100 7

Sample Output

21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67

#include<stdio.h>  
#define MAXN 1003  
#define bool _Bool  
#define false 0  
#define true 1  
bool prime[MAXN]={false};  
int stack[MAXN];  
int top;  
  
int num_prime(int to)  
{  
    int _i;  
    top=0;  
    for(_i=1;_i<=to;_i++)  
        if(prime[_i]) stack[top++]=_i;  
    return top;  
}  
int main()  
{  
    //freopen("input","r",stdin);  
    int i,j,n,c;  
    int num_p;  
    for(i=2;i<=MAXN;i++)  
    {  
        if(i%2) prime[i]=true;  
        //else prime[i]=false;//初始值就是false,可以省略  
    }  
    int tmp=(int)sqrt(MAXN);  
    for(i=3;i<=tmp;i++)  
    {  
        if(prime[i])  
        {  
            for(j=i+i;j<=MAXN;j+=i) prime[j]=false;  
        }  
    }  
    prime[1]=true;  
    prime[2]=true;  
    //  
    int index;  
    while(scanf("%d %d",&n,&c)!=EOF)  
    {  
        num_p=num_prime(n);  
        printf("%d %d: ",n,c);  
        if(num_p%2)  
        {  
            index=(num_p+1)/2;  
            if(index-c+1>0)  
                for(i=index-c;i<=index+c-2;i++) printf("%d ",stack[i]);  
            else  
                for(i=0;i<top;i++) printf("%d ",stack[i]);  
        }  
        else  
        {  
            if(num_p/2>c)  
                for(i=num_p/2-c;i<num_p/2+c;i++) printf("%d ",stack[i]);  
            else  
                for(i=0;i<top;i++) printf("%d ",stack[i]);  
        }  
        printf("/n/n");  
  
    }  
    //printf("%d/n",num_prime(10));  
    return 0;  
}  

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值