UVA 424 Integer Inquiry

Integer Inquiry

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)


Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.


Output

Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input



123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0


Sample Output

370370367037037036703703703670


简单的高精度加法,不过要注意输入,而且数据貌似第一位有是0的,被坑了。。不过高精度加法的模板真是好用啊。

#include<iostream>  
#include<algorithm>
#include<math.h>
#include<cstdio>
#include<string>
#include<string.h>
using namespace std;
const int maxn = 300;
const int base = 10;
struct bignum
{
	int len, s[maxn];
	bignum() { memset(s, 0, sizeof(s)); len = 1; }
	bignum operator = (const bignum &b)
	{
		len = b.len;
		memcpy(s, b.s, maxn*sizeof(int));
		return *this;
	}
};

bignum operator +(const bignum &a, const bignum &b)
{
	bignum c;
	int jw = 0, i;
	for (i = 0; i < max(b.len, a.len) || jw>0; i++)
	{
		if (i < a.len) jw += a.s[i];
		if (i < b.len) jw += b.s[i];
		c.s[i] = jw % base;		jw /= base;
	}
	c.len = i;		return c;
}

bignum insert(char *s)
{
	bignum c;
	c.len = strlen(s);
	for (int i = c.len - 1; i >= 0; i--) c.s[i] = s[c.len - i - 1] - '0';
	while (c.s[c.len - 1] == 0) c.len--;
	return c;
}

int t;
char s[2000];

int main(){
	cin >> t;	getchar();
	while (t--)
	{
		bignum f;
		while (~scanf("%s", s))
		{
			if (s[0] == '0'&&strlen(s) == 1) break;
			bignum k = insert(s);
			f = f + k;
		}
		for (int i = f.len - 1; i >= 0; i--) printf("%d", f.s[i]);
		printf("\n");
		if (t) printf("\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值