POJ 2411 Mondriaan's Dream

98 篇文章 0 订阅
15 篇文章 0 订阅

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205
 
  
采用2进制保存每个点的情况,下一层总是由上一层的状态递推而来。
然后通过搜索来判断横向的方块如何放置。
 
  
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=12;
int n,m,N;
long long f[maxn][1<<maxn];
int ins[1<<maxn];
int c[maxn]={3,6,12,24,48,96,192,384,768,1536,3072,6144};

long long dfs(int x,int y)
{
	long long tot=0;
	for (int k=0;k<maxn&&c[k]<=y;k++)
		if ((c[k]&y)==c[k]&&ins[y-c[k]]==0)
		{	
			ins[y-c[k]]=1;
			tot+=dfs(x,y-c[k]);
		}
	return tot+f[x][y];
}

int main()
{
	while (~scanf("%d%d",&n,&m),n+m)
	{
		memset(f,0,sizeof(f));
		m=(1<<m)-1;	f[1][0]=1;
		for (int i=1;i<=n;i++)
			for (int j=m;j>=0;j--) 
				memset(ins,0,sizeof(ins)),f[i+1][j^m]+=f[i][j]=dfs(i,j);
		cout<<f[n][m]<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值