HDU 5310 Souvenir

42 篇文章 0 订阅
Problem Description

Today is the 1st anniversary of BestCoder. Soda, the contest manager, wants to buy a souvenir for each contestant. You can buy the souvenir one by one or set by set in the shop. The price for a souvenir is pp yuan and the price for a set of souvenirs if qq yuan. There's mm souvenirs in one set.

There's nn contestants in the contest today. Soda wants to know the minimum cost needed to buy a souvenir for each contestant.

Input

There are multiple test cases. The first line of input contains an integer TT (1 \le T \le 10^5)(1T105), indicating the number of test cases. For each test case:

There's a line containing 4 integers n, m, p, qn,m,p,q (1 \le n, m, p, q \le 10^4)(1n,m,p,q104).

Output

For each test case, output the minimum cost needed.

Sample Input
2
1 2 2 1
1 2 3 4
Sample Output
1
3


   
   
Hint
For the first case, Soda can use 1 yuan to buy a set of 2 souvenirs.

For the second case, Soda can use 3 yuan to buy a souvenir.

简单题

考虑三种情况即可

#include<cstdio>
#include<cmath>
#include<queue>
#include<vector>
#include<stack>
#include<map>
#include<string>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
const ll maxn = 100005;
int T, n, m, p, q, ans;

int main()
{
    cin >> T;
    while (T--)
    {
        scanf("%d%d%d%d", &n, &m, &p, &q);
        ans = n * p;
        ans = min(ans, n / m * q + n % m * p);
        ans = min(ans, (n + m - 1) / m * q);
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值