HDU 5399 Too Simple

Problem Description
Rhason Cheung had a simple problem, and asked Teacher Mai for help. But Teacher Mai thought this problem was too simple, sometimes naive. So she ask you for help.

Teacher Mai has  m  functions  f1,f2,,fm:{1,2,,n}{1,2,,n} (that means for all  x{1,2,,n},f(x){1,2,,n} ). But Rhason only knows some of these functions, and others are unknown.

She wants to know how many different function series  f1,f2,,fm  there are that for every  i(1in) , f1(f2(fm(i)))=i . Two function series  f1,f2,,fm  and  g1,g2,,gm  are considered different if and only if there exist  i(1im),j(1jn) , fi(j)gi(j) .
 

Input
For each test case, the first lines contains two numbers  n,m(1n,m100) .

The following are  m  lines. In  i -th line, there is one number  1  or  n  space-separated numbers.

If there is only one number  1 , the function  fi  is unknown. Otherwise the  j -th number in the  i -th line means  fi(j) .
 

Output
For each test case print the answer modulo  109+7 .
 

Sample Input
  
  
3 3 1 2 3 -1 3 2 1
 

Sample Output
  
  
1
Hint
The order in the function series is determined. What she can do is to assign the values to the unknown functions.

这题其实很简单,对于多于两个-1的情况不管之前那个怎么选,只要最后一个固定就可以保证,所以答案就是(n!)^(m-1) m是-1的个数

不过此题坑比较多,要注意判断

#pragma comment(linker, "/STACK:1024000000,1024000000") 
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const LL base = 1e9 + 7;
const int maxn = 105;
LL T, n, m, f[maxn], a[maxn][maxn];

inline void read(int &x)
{
    char ch;
    while ((ch = getchar())<'0' || ch>'9');
    x = ch - '0';
    while ((ch = getchar()) >= '0' && ch <= '9') x = x * 10 + ch - '0';
}

int main()
{
    //read(T);
    for (int i = f[0] = 1; i <= 100; i++) f[i] = f[i - 1] * i % base;
    while (scanf("%I64d%I64d", &n, &m) != EOF)
    {
        LL tot = 0, ans = 1;
        for (int i = 1; i <= m; i++)
        {
            scanf("%I64d", &a[i][1]);
            if (a[i][1] == -1) tot++;
            else for (int j = 2; j <= n; j++)
            {
                scanf("%I64d", &a[i][j]);
                for (int k = j - 1; k; k--) if (a[i][j] == a[i][k]) ans = 0;
            }
        }
        for (int i = 1; i < tot; i++) ans = ans * f[n] % base;
        if (tot == 0)
        {
            for (int i = 1; i <= n; i++) a[0][i] = i;
            for (int i = m; i; i--)
                for (int j = 1; j <= n; j++) a[0][j] = a[i][a[0][j]];
            for (int i = 1; i <= n; i++) if (a[0][i] != i) ans = 0;
        }
        printf("%I64d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值