HDU 5430 Reflect

Problem Description
We send a light from one point on a mirror material circle,it reflects  N  times and return the original point firstly.Your task is calcuate the number of schemes.


 

Input
First line contains a single integer  T(T10)  which denotes the number of test cases. 

For each test case, there is an positive integer  N(N106) .
 

Output
For each case, output the answer.
 

Sample Input
  
  
1 4
 

Sample Output
  
  
4
 


妥妥的欧拉函数

#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<cstdio>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1000005;
int T, n, m, p[maxn];

void phi()
{
    int N = maxn;
    for (int i = 1; i<N; i++)  p[i] = i;
    for (int i = 2; i<N; i += 2) p[i] >>= 1;
    for (int i = 3; i<N; i += 2)
    {
        if (p[i] == i)
        {
            for (int j = i; j<N; j += i)
                p[j] = p[j] - p[j] / i;
        }
    }
}

int main()
{
    phi();
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        printf("%d\n", p[n + 1]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值