HDU 4433 locker

Problem Description
A password locker with N digits, each digit can be rotated to 0-9 circularly.
You can rotate 1-3 consecutive digits up or down in one step.
For examples:
567890 -> 567901 (by rotating the last 3 digits up)
000000 -> 000900 (by rotating the 4th digit down)
Given the current state and the secret password, what is the minimum amount of steps you have to rotate the locker in order to get from current state to the secret password?
 

Input
Multiple (less than 50) cases, process to EOF.
For each case, two strings with equal length (≤ 1000) consists of only digits are given, representing the current state and the secret password, respectively.
 

Output
For each case, output one integer, the minimum amount of steps from the current state to the secret password.
 

Sample Input
  
  
111111 222222 896521 183995
 

Sample Output
  
  
2 12
 


f[now][i][j]表示从第1位到第now位全部已经对上且现在第now+1位是i,第now+2位是j的最少步数,然后递推转移即可

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1005;
char s1[maxn],s2[maxn];
int f[maxn][10][10],n,a[maxn],b[maxn],ans;

void get(int a,int b,int c,int x)
{
    if (f[a][b][c]<0) f[a][b][c]=x;
    else f[a][b][c]=min(f[a][b][c],x);
}

int main()
{
    while (~scanf("%s%s",s1,s2))
    {
        n=strlen(s1);        ans=9*n;
        for (int i=1;i<=n;i++) a[i]=s1[i-1]-'0',b[i]=s2[i-1]-'0';
        a[n+1]=a[n+2]=b[n+1]=b[n+2]=0;

        for (int i=0;i<=n;i++) memset(f[i],-1,sizeof(f[i]));
        f[0][a[1]][a[2]]=0;
        for (int now=0;now<n;now++)
        {
            int end=a[now+3];
            for (int i=0;i<10;i++)
            {
                int up=(b[now+1]-i+10)%10;
                int dw=(i-b[now+1]+10)%10;
                for (int j=0;j<10;j++)
                    if (f[now][i][j]>=0)
                    {
                        for (int k=0;k<=up;k++)
                            for (int kk=0;kk<=k;kk++)
                                get(now+1,(j+k)%10,(end+kk)%10,f[now][i][j]+up);
                        for (int k=0;k<=dw;k++)
                            for (int kk=0;kk<=k;kk++)
                                get(now+1,(10+j-k)%10,(10+end-kk)%10,f[now][i][j]+dw);
                    }
            }
        }
        for (int i=0;i<10;i++)
            for (int j=0;j<10;j++)
                if (f[n][i][j]>=0) ans=min(f[n][i][j],ans);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值