HDU 5591 ZYB's Game

Problem Description

ZYBZYB played a game named Number BombNumberBomb with his classmates in hiking:a host keeps a number in [1,N][1,N] in mind,then players guess a number in turns,the player who exactly guesses XX loses,or the host will tell all the players that the number now is bigger or smaller than XX.After that,the range players can guess will decrease.The range is [1,N][1,N] at first,each player should guess in the legal range.

Now if only two players are play the game,and both of two players know the XX,if two persons all use the best strategy,and the first player guesses first.You are asked to find the number of XX that the second player will win when XX is in [1,N][1,N].

Input

In the first line there is the number of testcases TT.

For each teatcase:

the first line there is one number NN.

1 \leq T \leq 1000001T100000,1 \leq N \leq 100000001N10000000

Output

For each testcase,print the ans.

Sample Input
1
3
Sample Output
1

简单题,直接推导一下就好

#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e7 + 5;
int T, n, m;

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        printf("%d\n", n & 1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值