POJ 2828 Buy Tickets

35 篇文章 0 订阅
18 篇文章 0 订阅

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posiand Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

看到题意直接上的splay,奈何常数太大,无限超时啊,正解是倒过来,线段树啊,树状数组啊随便维护的

splay超时版
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<map>
#include<algorithm>
#include<bitset>
#include<functional>
using namespace std;
typedef unsigned long long ull;
typedef long long LL;
const int maxn = 3e5 + 10;
int n, root, x, y, flag;

struct Splays
{
	const static int maxn = 3e5 + 10;			//节点个数
	const static int INF = 0x7FFFFFFF;			//int最大值
	int ch[maxn][2], F[maxn], sz;				//左右儿子,父亲节点和节点总个数
	int C[maxn], V[maxn];
	int Node(int f, int v) { C[sz] = 1; V[sz] = v; ch[sz][0] = ch[sz][1] = 0; F[sz] = f; return sz++; }//申请一个新节点
	void clear(){ sz = 1; ch[0][0] = ch[0][1] = F[0] = 0; C[0] = 0; }//清空操作
	void rotate(int x, int k)
	{
		int y = F[x]; ch[y][!k] = ch[x][k]; F[ch[x][k]] = y;
		if (F[y]) ch[F[y]][y == ch[F[y]][1]] = x;
		F[x] = F[y];    F[y] = x;	ch[x][k] = y;
		C[x] = C[y];	C[y] = C[ch[y][0]] + C[ch[y][1]] + 1;
	}
	void Splay(int x, int r)
	{
		for (int fa = F[r]; F[x] != fa;)
		{
			if (F[F[x]] == fa) { rotate(x, x == ch[F[x]][0]); return; }
			int y = x == ch[F[x]][0], z = F[x] == ch[F[F[x]]][0];
			y^z ? (rotate(x, y), rotate(x, z)) : (rotate(F[x], z), rotate(x, y));
		}
	}
	void build(int &x, int l, int r)
	{
		x = Node(0, -1);
		ch[x][1] = Node(x, -1);
		C[x]++;
	}
	void insert(int &x, int u, int v)
	{
		for (int i = x; i;)
		{
			if (C[ch[i][0]] > u){ i = ch[i][0]; continue; }
			if (C[ch[i][0]] == u) { Splay(i, x); x = i; break; }
			u -= C[ch[i][0]] + 1;	i = ch[i][1];
		}
		for (int i = ch[x][1]; i; i = ch[i][0])
		{
			if (!ch[i][0]) { Splay(i, ch[x][1]); ch[x][1] = i; break; }
		}
		int now = ch[ch[x][1]][0] = Node(ch[x][1], v);
		C[ch[x][1]]++;	C[x]++;
		Splay(now, x);	x = now;
	}
	void putout(int x)
	{
		if (ch[x][0]) putout(ch[x][0]);
		if (V[x] != -1)
		{
			printf("%s%d", flag ? " " : "", V[x]);
			flag = 1;
		}
		if (ch[x][1]) putout(ch[x][1]);
	}
}solve;

int main()
{
	while (scanf("%d", &n) != EOF)
	{
		solve.clear();	root = 0;
		solve.build(root, 0, n + 1);
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &x, &y);
			solve.insert(root, x , y);
		}
		flag = 0;
		solve.putout(root);
		printf("\n");
	}
	return 0;
}
正解
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<map>
#include<algorithm>
#include<bitset>
#include<functional>
using namespace std;
typedef unsigned long long ull;
typedef long long LL;
const int low(int x){ return x&-x; }
const int maxn = 3e5 + 10;
int n, x[maxn], y[maxn], ans[maxn], f[maxn];

void add(int x, int y)
{
	for (int i = x; i <= n; i += low(i)) f[i] += y;
}

int get(int x)
{
	int res = 0;
	for (int i = x; i; i -= low(i)) res += f[i];
	return res;
}

int main()
{
	while (scanf("%d", &n) != EOF)
	{
		for (int i = 1; i <= n; i++) scanf("%d%d", &x[i], &y[i]);
		for (int i = 1; i <= n; i++) f[i] = 0;
		for (int i = 1; i <= n; i++) add(i, 1);
		for (int i = n; i; i--)
		{
			int q = 1, h = n;
			while (q <= h)
			{
				int mid = q + h >> 1, res = get(mid);
				if (res < x[i] + 1) q = mid + 1; else h = mid - 1;
			}
			ans[q] = y[i];
			add(q, -1);
		}
		for (int i = 1; i <= n; i++) printf("%d%s", ans[i], i == n ? "\n" : " ");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值