HDU 5682 zxa and leaf

21 篇文章 0 订阅


Problem Description
zxa have an unrooted tree with  n  nodes, including  (n1)  undirected edges, whose nodes are numbered from  1  to  n . The degree of each node is defined as the number of the edges connected to it, and each node whose degree is  1  is defined as the leaf node of the tree.

zxa wanna set each node's beautiful level, which must be a positive integer. His unrooted tree has  m(1mn)  leaf nodes,  k(1km)  leaf nodes of which have already been setted their beautiful levels, so that zxa only needs to set the other nodes' beautiful levels.

zxa is interested to know, assuming that the ugly level of each edge is defined as the absolute difference of the beautiful levels between two nodes connected by this edge, and the ugly level of the tree is the maximum of the ugly levels of **all the edges on this tree**, then what is the minimum possible ugly level of the tree, can you help him?
 

Input
The first line contains an positive integer  T , represents there are  T  test cases.

For each test case:

The first line contains two positive integers  n  and  k , represent the tree has  n  nodes,  k  leaf nodes of which have already been setted their beautiful levels.

The next  (n1)  lines, each line contains two distinct positive integers  u  and  v , repersent there is an undirected edge between node  u  and node  v .

The next  k  lines, each lines contains two positive integers  u  and  w , repersent node  u  is a leaf node, whose beautiful level is  w .

There is a blank between each integer with no other extra space in one line.

It's guaranteed that the input edges constitute a tree.

1T10,2n5104,1kn,1u,vn,1w109
 

Output
For each test case, output in one line a non-negative integer, repersents the minimum possible ugly level of the tree.
 

Sample Input
  
  
2 3 2 1 2 1 3 2 4 3 9 6 2 1 2 1 3 1 4 2 5 2 6 3 6 5 9
 

Sample Output
  
  
3 1
Hint
If you need a larger stack size, please use #pragma comment(linker, "/STACK:102400000,102400000") and submit your solution using C++.
要保证最大的边最小,直接去做一般是很难的,这里通过二分答案然后用拓扑排序的方式验证答案。
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<bitset>
#include<string>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;
int T, n, m;
int x, y, l, r;
int q[maxn], h[maxn];

int ft[maxn], nt[maxn], u[maxn], ct[maxn], sz, f[maxn];
int mx[maxn], vis[maxn];

bool check(int x)
{
    queue<int> p;
    for (int i = 1; i <= n; i++)
    {
        if ((mx[i] = ct[i]) == 1) p.push(i);
        vis[i] = 0;
        if (f[i]) q[i] = h[i] = f[i];
        else q[i] = l, h[i] = r;
    }
    while (!p.empty())
    {
        int pp = p.front();    p.pop();    vis[pp] = 1;
        int L = max(l, q[pp] - x), R = min(r, h[pp] + x);
        for (int i = ft[pp]; i != -1; i = nt[i])
        {
            if (vis[u[i]]) continue;
            if (--mx[u[i]] == 1) p.push(u[i]);
            q[u[i]] = max(q[u[i]], L);
            h[u[i]] = min(h[u[i]], R);
            if (q[u[i]] > h[u[i]]) return false;
         }
    }
    return true;
}

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d", &n, &m);
        sz = 0;
        for (int i = 1; i <= n; i++) ft[i] = -1, f[i] = ct[i] = 0;
        for (int i = 1; i < n; i++)
        {
            scanf("%d%d", &x, &y);
            u[sz] = y;    nt[sz] = ft[x];    ft[x] = sz++;
            u[sz] = x;    nt[sz] = ft[y];    ft[y] = sz++;
            ct[x]++;    ct[y]++;
        }
        l = INF;    r = 0;
        for (int i = 1; i <= m; i++)
        {
            scanf("%d%d", &x, &y);
            f[x] = y;
            l = min(l, y);
            r = max(y, r);
        }
        if (n == 2)
        {
            if (m == 2) printf("%d\n", abs(f[1] - f[2]));
            else printf("0\n");    continue;
        }
        int a = 0, b = r - l;
        while (a <= b)
        {
            int mid = a + b >> 1;
            if (check(mid)) b = mid - 1; else a = mid + 1;
        }
        printf("%d\n", a);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值