HDU 4861 Couple doubi

DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
Input
Multiply Test Cases. 
In the first line there are two Integers k and p(1<k,p<2^31). 
Output
For each line, output an integer, as described above.
Sample Input
2 3
20 3
Sample Output
YES

NO

打表找规律,可以发现,循环节是p-1,每p-1有一个正数p-1,其余都是0。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<stack>
#include<algorithm>
using namespace std;
int k,p;

int main()
{
    while(~scanf("%d%d",&k,&p))
    {
        /*
        for (int i=1;i<=k;i++)
        {
            int res=0;
            for (int j=1;j<p;j++)
            {
                int now=1;
                for (int k=1;k<=i;k++)
                {
                    now=now*j%p;
                }
                res=(res+now)%p;
            }
            printf("%d %d\n",i,res);
        }*/
        puts(k/(p-1)%2?"YES":"NO");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值