Where is the Marbl

Raju and Meena love to play with Marbles. They have got a lot ofmarbles with numbers written on them. At the beginning, Raju wouldplace the marbles one after another in ascending order of the numberswritten on them. Then Meena would ask Raju to find the first marblewith a certain number. She would count 1...2...3. Raju gets one pointfor correct answer, and Meena gets the point if Raju fails. After somefixed number of trials the game ends and the player with maximumpoints wins. Today it’s your chance to play as Raju. Being the smartkid, you’d be taking the favor of a computer. But don’t underestimateMeena, she had written a program to keep track how much time you’retaking to give all the answers. So now you have to write a program,which will help you in your role as Raju.

InputThere can be multiple test cases. Total no of test cases is less than 65. Each test case consists beginswith 2 integers: N the number of marbles and Q the number of queries Mina would make. The nextN lines would contain the numbers written on the N marbles. These marble numbers will not comein any particular order. Following Q lines will have Q queries. Be assured, none of the input numbersare greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

OutputFor each test case output the serial number of the case.For each of the queries, print one line of output. The format of this line will depend upon whetheror not the query number is written upon any of the marbles. The two different formats are describedbelow:• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered1, 2, . . . , N.• ‘x not found’, if the marble with number x is not present.Look at the output for sample input for details.

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

题意:就是给出一组数据,查找某个数在不在其中。

题解:这组数据按从小到大排列,然后再查询一个数是否在数组中,在的话输出排在第几。

Select Code

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
int x[10010];
int Find(int len,int top,int f)
{
    int mid;
    while(len<=top)
    {
        mid=(len+top)/2;
        if(x[mid]==f)
            return mid;
        else if(f<x[mid])
            top=mid-1;
        else if(f>x[mid])
            len=mid+1;
    }
    return -1;
}
int main()
{
      int y,i,count=0,a,n,d;
      while(scanf("%d %d",&n,&a)&&a!=0&&n!=0)
      {
          getchar();
          count++;
          for(i=0;i<n;i++)
          {
              scanf("%d",&x[i]);
              getchar();
          }
          sort(x,x+n);
          printf("CASE# %d:\n",count);
          for(i=0;i<a;i++)
    {
                scanf("%d",&y);
                d=Find(0,n-1,y);
              if(d==-1)
              {
                  printf("%d not found\n",y);
              }
              else
              {
                  while(d>0&&x[d]==x[d-1])
                  {
                      d--;
                  }
                  printf("%d found at %d\n",y,d+1);
              }
          }
      }

       return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值