Raicom-2023省赛题目~
题意:
A:最近出了一个饮料营养等级你们知道吗?例如无糖的饮料是 A 级,可乐是 D 级……
B:那……无糖可乐是什么级别?
C:AD 级吧。
A:出院!
B:出什么院,你也给我进去!
以上是某群中一段有趣的对话。请你按照里面的逻辑,在已知某些饮料的等级的情况下,给饮料定级。定级的方法是:
- 如果是已知等级的饮料,直接输出等级;
- 对于一个新饮料的名字,你需要将名字拆成两个已知等级的部分,然后输出这个级别。例如:Diet是A,Coke是D,那么DietCoke就是AD;
- 如果新饮料无法拆解或者有多种拆解方法,统一定为 D 级。
输入格式:
输入第一行是两个正整数 N,M (1≤N,M≤100),表示已知的饮料有 N 种,需要定级的饮料有 M 种。
接下来首先是 N 行,每行是一个字符串和一个字符,表示一种饮料的名字和对应的等级,等级只有 A,B,C,D 四种。
然后是 M 行,每行是一个字符串,表示需要定级的饮料的名字。
所有饮料名字只包含有大小写字母,长度不超过 30,给定拥有等级的饮料的名字不会重复。
输出格式:
对于每一个需要定级的饮料,输出定好的定级。
输入样例:
5 6
Diet A
LowSugarTea B
Milk C
Coke D
Water A
DietCoke
Pepsi
Milk
CokeWater
GoodMilk
dietCoke
输出样例:
AD
D
C
DA
D
D
代码:【C++】
有问题可评论区留言。作者很勤快的~每天都会上线~_~。
注释较多,代码不多。耐心看完~
方法一:【主要使用STL-string】
// 考点:stl-string.
# include<bits/stdc++.h>
using namespace std;
const int maxn=110;
struct lable{
string name;
string label;
}product[maxn];
int main(){
int n,m,nn,i=0;
cin>>n>>m;
nn = n;
while(n--){
cin>>product[i].name>>product[i].label;
i++;
}
string temp_name,temp_label; // 待判断等级的饮料及其标签
string matched; // matched存着每一个待判断等级的饮料(temp_name)中:已匹配好等级部分的字符串。
// matched的作用在于,可以甄别出这种情况:对于只有部分字符串匹配的饮料名,赋予等级D。
while(m--){
// 处理一组输出一组
cin>>temp_name;
for(int i=0;i<nn;i++){ // 遍历所有已知标签的饮料
// 关键是如何保证新饮料(尤其是多标签)的标签顺序问题。。。。
/*MilkDiet CA AC*/
if(temp_name.find(product[i].name)==string::npos){ // 如果在当前新饮料名字符串内没找到 当轮已知标签的饮料名
continue;
}else if(temp_name.find(product[i].name)==0){// 如果在当前新饮料名字符串内找到 当轮已知标签的饮料名,且匹配的字符串位于新饮料名字符串的前半段
temp_label.insert(0,product[i].label);
matched.insert(0,product[i].name);
}else{// 如果在当前新饮料名字符串内找到 当轮已知标签的饮料名,且匹配的字符串位于新饮料名字符串的后半段
if(temp_label.size()!=0)
temp_label.insert(1,product[i].label);
else
temp_label.insert(0,product[i].label);
matched.insert(0,product[i].name);
}
}
// 新饮料名只有部分字符串匹配或一个名称有多个标签的情况,则赋予标签D
if((matched.size()!=temp_name.size()) || temp_label.size()==3){
/* 之所以是3,因为:
首先,根据题意可知,待判断等级的饮料名要么没标签(D),要么一个标签(如C、A),要么两个标签(如AB、CA)
新饮料名真实标签只有一个字符时,不可能存在含有多个标签的情况(题目保证已知“饮料-标签”是唯一的),
新饮料真实标签是两个字符时,一个饮料标签产生混淆的情况下,标签数只可能是3。例子可见下方。
不可能是4(如某饮料名既可能是AB也可能是CA)是因为题目保证已知“饮料-标签”是唯一的 */
/* 一个名称有多个标签的例子:
已知 mile C coke D milkcoke A
则新饮料名milecoke存在两个标签:CD 或 A。这种情况应该赋予标签D。
*/
cout << "D" <<endl;
}else{
cout << temp_label <<endl;
}
// 每轮待判断等级的饮料结束判级后,清除相关字符串中的内容。
temp_label.clear();
temp_name.clear();
matched.clear();
}
return 0;
}
方法二:【综合使用STL-string、STL-map】
方法二的第一种写法:
#include<bits/stdc++.h>
using namespace std;
int main(){
int n,m;
map<string,string> mp;
cin>>n>>m;
string temp_drink,temp_label;//已知的饮料名及其标签
while(n--){
cin>>temp_drink>>temp_label;
mp[temp_drink]=temp_label;
}
// for(map<string,string>::iterator it = mp.begin();it!=mp.end();it++)
// cout << it->first << " " << it->second << endl;
temp_drink.clear();//temp_drink变量继续使用,用来接收未判级的饮料名
temp_label.clear();//temp_label变量继续使用,用来存放未判级的饮料名的标签
while(m--){
// 来一组数据处理一组
int cnt = 0;//记录饮料名存在多少个标签
cin >> temp_drink;
if(mp.count(temp_drink)){
temp_label = mp[temp_drink];
cnt++;
}
for(int i = 1;i<temp_drink.size();i++){ // i是截取字符串的长度
string s1 = temp_drink.substr(0,i);
string s2 = temp_drink.substr(i);
if(mp.count(s1)&&mp.count(s2)){
cnt++; // 新饮料名匹配标签+1
temp_label = mp[s1] + mp[s2];
}
s1.clear();
s2.clear();
}
if(cnt>1 || temp_label.size()==0)
cout << "D" <<endl;
else
cout << temp_label << endl;
temp_drink.clear();
temp_label.clear();
cnt = 0;
}
return 0;
}
方法二的第二种写法:
#include<bits/stdc++.h>
#include<map>
using namespace std;
int main(){
int n,m;
map<string,string> mp;
cin>>n>>m;
while(n--){
string yinliao,rank;
cin>>yinliao>>rank;
mp[yinliao]=rank;
}
// for(map<string,string>::iterator it=mp.begin();it!=mp.end();it++){
// cout<<it->first<<" "<<it->second<<endl;
// } // 测试输入
while(m--){
// 来一个处理一个
string yinliao;
cin >> yinliao;
string temp_rank;//当前饮料的等级
int should_num;//当前饮料应有的评级个数。如果存在评级,则要么1,要么2。
for(map<string,string>::iterator it=mp.begin();it!=mp.end();it++){
string temp = it->first;// 遍历当前已有饮料名
if(yinliao==temp){ // 已知等级的饮料
temp_rank=it->second;
should_num=1;
break;
}
if(yinliao.find(temp)==-1) // mp当前遍历到的键值对的键未出现在当前饮料名中
continue;
else if(yinliao.find(temp)==0){ // mp当前遍历到的键值对的键位于当前饮料名的前半部分
should_num=2;
temp_rank.insert(0,it->second);
}else{ // mp当前遍历到的键值对的键位于当前饮料名的后半部分
int pos=1;
if(temp_rank.size()==0) pos=0;
should_num=2;
temp_rank.insert(pos,it->second);
}
}
if(temp_rank.size()==0 || temp_rank.size()!=should_num ||temp_rank.size()>2){
cout<<"D"<<endl; // 无法拆解或存在多种拆解方法
continue;
}
cout << temp_rank << endl;
}
return 0;
}
测试样例参考:
以下两个案例是作者自己构造的测试样例,可作为您程序的测试样例。
输入样例1:
5 6
Diet A
LowSugarTea B
Milk C
Coke D
Water A
DietCoke
Pepsi
Milk
CokeWater
GoodMilk
dietCoke
输出样例1:
AD
D
C
DA
D
D
输入样例2:
8 6
Diet A
Die B
tCoke D
LowSugarTea B
Milk C
Coke D
Water A
DietCoke C
DietCoke
Pepsi
Milk
CokeWater
GoodMilk
dietCoke
输出样例2:
D
D
C
DA
D
D