hdu1050 贪心

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output10
20
30

贪心入门题没什么好说的,就是挖的坑有点多,1到3 和4到5 看似没什么冲撞,其实 3和4还是撞了,所以把所有的奇数都+1,用同一列的偶数表示就完了,
贪心过程就是把所有的区间按照起点排序,优先队列维护终点,放不下就新加一组时间来推箱子,
贪心的正确性的证明:每次增加新的时间以为着在这段时间里起码有当前个过道被占用,
所以起码 最少要当前时间加1来维护,而这样填补的过程又刚好可以构造一个这样的序列证明可以取到这么少的时间就完成了
以下给出ac代码:

#include <stdio.h>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
typedef pair<int,int>pii;
const int maxn=210;
pii q[maxn];

int main()
{
    int t,n,a,b;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d%d",&a,&b);
            if(a>b)swap(a,b);
            if(a&1)a++;if(b&1)b++;
            q[i]={a,b};
        }
        sort(q,q+n);
        priority_queue<int,vector<int>,greater<int> >path;
        path.push(-1e6);
        for(int i=0;i<n;i++){
            int last=path.top();
            if(q[i].first>last){
                path.pop();
                path.push(q[i].second);
            }else{
                path.push(q[i].second);
            }
            }
        printf("%d\n",path.size()*10);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值