[SNCPC2019] Digit Product(思维&数学)

题面翻译

【题目描述】

定义正整数 x x x 的 “数字乘积” f ( x ) f(x) f(x) 为其所有数字的乘积。例如, f ( 1234 ) = 1 × 2 × 3 × 4 = 24 f(1234) = 1 \times 2 \times 3 \times 4 = 24 f(1234)=1×2×3×4=24 f ( 100 ) = 1 × 0 × 0 = 0 f(100) = 1 \times 0 \times 0 = 0 f(100)=1×0×0=0

给定两个整数 l l l r r r,请计算以下值:
( ∏ i = l r f ( i ) ) m o d    ( 1 0 9 + 7 ) (\prod_{i=l}^r f(i)) \mod (10^9+7) (i=lrf(i))mod(109+7)
如果你不知道 ∏ \prod 表示什么,上述表达式等同于
( f ( l ) × f ( l + 1 ) × ⋯ × f ( r ) ) m o d    ( 1 0 9 + 7 ) (f(l) \times f(l+1) \times \dots \times f(r)) \mod (10^9+7) (f(l)×f(l+1)××f(r))mod(109+7)

【输入格式】

有多个测试用例。输入的第一行包含一个整数 T T T(大约 1 0 5 10^5 105),表示测试用例的数量。对于每个测试用例:

第一行且唯一一行包含两个整数 l l l r r r 1 ≤ l ≤ r ≤ 1 0 9 1 \le l \le r \le 10^9 1lr109),表示给定的两个整数。这些整数没有前导零。

【输出格式】

对于每个测试用例,输出一行,包含一个整数,表示答案。

【样例解释】

对于第一个样例测试用例,答案是 9 ! m o d    ( 1 0 9 + 7 ) = 362880 9! \mod (10^9+7) = 362880 9!mod(109+7)=362880

对于第二个样例测试用例,答案是 ( f ( 97 ) × f ( 98 ) × f ( 99 ) ) m o d    ( 1 0 9 + 7 ) = ( 9 × 7 × 9 × 8 × 9 × 9 ) m o d    ( 1 0 9 + 7 ) = 367416 (f(97) \times f(98) \times f(99)) \mod (10^9+7) = (9 \times 7 \times 9 \times 8 \times 9 \times 9) \mod (10^9+7) = 367416 (f(97)×f(98)×f(99))mod(109+7)=(9×7×9×8×9×9)mod(109+7)=367416

翻译来自于:ChatGPT

题目描述

Define the ‘‘digit product’’ f ( x ) f(x) f(x) of a positive integer x x x as the product of all its digits. For example, f ( 1234 ) = 1 × 2 × 3 × 4 = 24 f(1234) = 1 \times 2 \times 3 \times 4 = 24 f(1234)=1×2×3×4=24, and f ( 100 ) = 1 × 0 × 0 = 0 f(100) = 1 \times 0 \times 0 = 0 f(100)=1×0×0=0.

Given two integers l l l and r r r, please calculate the following value:
( ∏ i = l r f ( i ) ) m o d    ( 1 0 9 + 7 ) (\prod_{i=l}^r f(i)) \mod (10^9+7) (i=lrf(i))mod(109+7)
In case that you don’t know what ∏ \prod represents, the above expression is the same as
( f ( l ) × f ( l + 1 ) × ⋯ × f ( r ) ) m o d    ( 1 0 9 + 7 ) (f(l) \times f(l+1) \times \dots \times f(r)) \mod (10^9+7) (f(l)×f(l+1)××f(r))mod(109+7)

输入格式

There are multiple test cases. The first line of the input contains an integer T T T (about 1 0 5 10^5 105), indicating the number of test cases. For each test case:

The first and only line contains two integers l l l and r r r ( 1 ≤ l ≤ r ≤ 1 0 9 1 \le l \le r \le 10^9 1lr109), indicating the given two integers. The integers are given without leading zeros.

输出格式

For each test case output one line containing one integer indicating the answer.

样例 #1

样例输入 #1

2
1 9
97 99

样例输出 #1

362880
367416

提示

For the first sample test case, the answer is 9 ! m o d    ( 1 0 9 + 7 ) = 362880 9! \mod (10^9+7) = 362880 9!mod(109+7)=362880.

For the second sample test case, the answer is ( f ( 97 ) × f ( 98 ) × f ( 99 ) ) m o d    ( 1 0 9 + 7 ) = ( 9 × 7 × 9 × 8 × 9 × 9 ) m o d    ( 1 0 9 + 7 ) = 367416 (f(97) \times f(98) \times f(99)) \mod (10^9+7) = (9 \times 7 \times 9 \times 8 \times 9 \times 9) \mod (10^9+7) = 367416 (f(97)×f(98)×f(99))mod(109+7)=(9×7×9×8×9×9)mod(109+7)=367416.

解析

如果区间存在 0 0 0 必定为 0 0 0,否则枚举。

#include<bits/stdc++.h>
using namespace std;
#define int long long
#define endl '\n'
#define inf 1e18
const int mod=1e9+7;
const int N=2e5+5;
int n,m;
int a[N];
void solve(){
	int l,r;
	cin>>l>>r;
	if(r-l>=9){
		cout<<0<<endl;
		return;
	}
	int f=1;
	for(int i=l;i<=r;i++){
		int x=i;
		while(x){
			f=(f*(x%10)%mod);
			x/=10;
		}
	}
	cout<<f%mod<<endl;
}
signed main(){
	ios::sync_with_stdio(false);
	cin.tie(nullptr);
	cout.tie(nullptr);
	int tt=1;
	cin>>tt;
	while(tt--) solve();
	return 0;
}
  • 20
    点赞
  • 22
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值