POJ3461:Oulipo(MP,KMP裸题)

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39112 Accepted: 15748

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

题意:求一个串在另一个串中出现的次数。

思路:

①MP算法,区别于BF算法那样的暴力循环,当遇到不匹配的字符时,不需要回到模式串的开头重新匹配,只需从next处继续即可,如下图:遇到a和b不等,但黑色部分A和B是一样的话,直接从A的右边处继续匹配,next数组需要预处理。


# include <stdio.h>
# include <string.h>
char s[10001], t[1000001];
int next[10001];//失配指针
int slen, tlen;

void init()
{
    memset(next, 0, sizeof(next));
    next[0] = next[1] = 0;
    for(int i=1; i<slen; ++i)
    {
        int j = next[i];
        while(j && s[i] != s[j]) j = next[j];
        next[i+1] = s[i]==s[j]?j+1:0;
    }
}

int kmp()
{
    int ans = 0, j = 0;
    for(int i=0; i<tlen; ++i)
    {
        while(j && t[i] != s[j]) j = next[j];
        if(t[i] == s[j]) ++j;
        if(j == slen)
        {
            ++ans;//计数器
            j = next[j];
        }
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",s,t);
        slen = strlen(s);
        tlen = strlen(t);
        init();
        printf("%d\n",kmp());
    }
    return 0;
}

②KMP实现:区别于MP,多开一个数组用于优化,失配指针更精确。

# include <stdio.h>
# include <string.h>
char s[10001], t[1000001];
int next[10001];//优化后的失配指针
int next2[10001];//原来的失配指针
int slen, tlen;

void init()
{
    memset(next, 0, sizeof(next));
    memset(next2, 0, sizeof(next2));
    next[0] = next[1] = 0;
    next2[0] = next2[1] = 0;
    for(int i=1; i<slen; ++i)
    {
        int j = next2[i];
        while(j && s[i] != s[j]) j = next[j];
        next2[i+1] = next[i+1] = s[i]==s[j]?j+1:0;
        if(next[i+1]==j+1 && s[i+1]==s[j+1])//这种情况下,指针可以继续往前跳。
            next[i+1] = next[j+1];
    }
}

int kmp()
{
    int ans = 0, j = 0;
    for(int i=0; i<tlen; ++i)
    {
        while(j && t[i] != s[j]) j = next[j];
        if(t[i] == s[j]) ++j;
        if(j == slen)
        {
            ++ans;//计数器
            j = next[j];
        }
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",s,t);
        slen = strlen(s);
        tlen = strlen(t);
        init();
        printf("%d\n",kmp());
    }
    return 0;
}


利用 TensorFlow 训练自己的目标识别器。本文内容来自于我的毕业设计,基于 TensorFlow 1.15.0,其他 TensorFlow 版本运行可能存在问题。.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值