HDU1247:Hat’s Words(字典树)

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14599    Accepted Submission(s): 5214


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
  
  
a ahat hat hatword hziee word
 

Sample Output
  
  
ahat hatword
 

Author
戴帽子的
 

题意:给定一堆单词,若一个单词能由其他两个单词拼接而成,就输出它。

思路:先将所有单词存到字典树里,再遍历每个单词,看能不能有两个组成。

# include <iostream>
# include <cstdio>
# include <cstring>
# define maxn 50000
using namespace std;
int n=0, cnt=0;
char s[maxn+3][20];

struct node
{
    int next[27], tag;
}tri[maxn+100]={0};

void add(char *s)
{
    int len = strlen(s), pos=0;
    for(int i=0; i<len; ++i)
    {
        int t = s[i]-'a';
        if(!tri[pos].next[t])
            tri[pos].next[t] = ++cnt;
        pos = tri[pos].next[t];
    }
    tri[pos].tag = 1;//tag为1表示存在以pos的节点结尾的单词。
}

bool query(char *s)
{
    int len = strlen(s), pos=0;
    for(int i=0; i<=len ;++i)
    {
        int t = s[i]-'a';
        if(tri[pos].next[t])
        {
            pos = tri[pos].next[t];
            if(tri[pos].tag)
            {
                int pos2 = 0, j=-1;
                for(j=i+1; j<len; ++j)
                {
                    int t2 = s[j]-'a';
                    if(!tri[pos2].next[t2]) break;
                    pos2 = tri[pos2].next[t2];
                    if(j == len-1 && tri[pos2].tag)
                        return true;
                }
            }
        }
       else
            return false;
    }
    return false;
}

int main()
{
    while(~scanf("%s",s[++n])) add(s[n]);
    for(int i=1; i<=n; ++i)
        if(query(s[i]))
            printf("%s\n",s[i]);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值