HDU2841:Visible Trees(莫比乌斯函数)

Visible Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3078    Accepted Submission(s): 1360


Problem Description
There are many trees forming a m * n grid, the grid starts from (1,1). Farmer Sherlock is standing at (0,0) point. He wonders how many trees he can see.

If two trees and Sherlock are in one line, Farmer Sherlock can only see the tree nearest to him.
 

Input
The first line contains one integer t, represents the number of test cases. Then there are multiple test cases. For each test case there is one line containing two integers m and n(1 ≤ m, n ≤ 100000)
 

Output
For each test case output one line represents the number of trees Farmer Sherlock can see.
 

Sample Input
  
  
2 1 1 2 3
 

Sample Output
  
  
1 5
 

Source

题意:人站在(0,0)点,有个n*m的树林,左下角在(1,1)处,问人可以看见多少棵树。

思路:gcd(i,j)不为1的点都不能看见,直接容斥即可,可以使用莫比乌斯反演。

# include <iostream>
# include <cstdio>
# include <cstring>
# include <algorithm>
# define ll long long
using namespace std;
const int maxn = 1e5;
short mu[maxn+3];
int prime[maxn+3];
bool bo[maxn+3];

void get_table()
{
    mu[1] = 1;
    memset(bo, 0, sizeof(bo));
    for(int i=2; i<=maxn; ++i)
    {
        if(!bo[i])
        {
            prime[++prime[0]] = i;
            mu[i] = -1;
        }
        for(int j=1; j<=prime[0]&&prime[j]*i<=maxn; ++j)
        {
            bo[i*prime[j]] = 1;
            if(i % prime[j] == 0)
            {
                mu[i*prime[j]] = 0;
                break;
            }
            else
                mu[i*prime[j]] = -mu[i];
        }
    }
    for(int i=1; i<=maxn; ++i)
        mu[i] += mu[i-1];//前缀和,用于分块。
}

int main()
{
    get_table();
    int t, n, m, j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        if(n > m) swap(n, m);
        ll ans = 0;
        for(int i=1; i<=n; i=j+1)
        {
            j = n/(n/i);//分块优化。
            ans += (ll)(mu[j]-mu[i-1])*(n/i)*(m/i);
        }
        printf("%lld\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值