Atcoder:TrBBnsformBBtion(思维 & 字符串)

E - TrBBnsformBBtion


Time limit : 2sec / Memory limit : 256MB

Score : 600 points

Problem Statement

Let us consider the following operations on a string consisting of A and B:

  1. Select a character in a string. If it is A, replace it with BB. If it is B, replace with AA.
  2. Select a substring that is equal to either AAA or BBB, and delete it from the string.

For example, if the first operation is performed on ABA and the first character is selected, the string becomes BBBA. If the second operation is performed on BBBAAAA and the fourth through sixth characters are selected, the string becomes BBBA.

These operations can be performed any number of times, in any order.

You are given two string S and T, and q queries ai,bi,ci,di. For each query, determine whether SaiSai+1Sbi, a substring of S, can be made into TciTci+1Tdi, a substring of T.

Constraints

  • 1|S|,|T|105
  • S and T consist of letters A and B.
  • 1q105
  • 1aibi|S|
  • 1cidi|T|

Input

Input is given from Standard Input in the following format:

S
T
q
a1 b1 c1 d1

aq bq cq dq

Output

Print q lines. The i-th line should contain the response to the i-th query. If SaiSai+1Sbi can be made into TciTci+1Tdi, print YES. Otherwise, print NO.


Sample Input 1

Copy
BBBAAAABA
BBBBA
4
7 9 2 5
7 9 1 4
1 7 2 5
1 7 2 4

Sample Output 1

Copy
YES
NO
YES
NO

The first query asks whether the string ABA can be made into BBBA. As explained in the problem statement, it can be done by the first operation.

The second query asks whether ABA can be made into BBBB, and the fourth query asks whether BBBAAAA can be made into BBB. Neither is possible.

The third query asks whether the string BBBAAAA can be made into BBBA. As explained in the problem statement, it can be done by the second operation.


Sample Input 2

Copy
AAAAABBBBAAABBBBAAAA
BBBBAAABBBBBBAAAAABB
10
2 15 2 13
2 13 6 16
1 13 2 20
4 20 3 20
1 18 9 19
2 14 1 11
3 20 3 15
6 16 1 17
4 18 8 20
7 20 3 14

Sample Output 2

Copy
YES
YES
YES
YES
YES
YES
NO
NO
NO
NO
题意:给定两个字符串s和t,有两个变换规则,A变成BB或B变成AA,删除AAA或删除BBB,给出q个询问,每个询问给a,b,c,d判断s串中a到b的子串能否通过变换成t串种c到d对的子串。

思路:通过写写画画发现A可以变成AAAA,但A,AA,AAA却不能互变,于是将字符串变成全A串,模3看看是否一样就行了。

# include <bits/stdc++.h>
using namespace std;

const int N = 1e5+3;
char s[N], t[N];
int sp[N], tp[N];
int main()
{
    int q, a, b, c,d;
    scanf("%s%s%d",s+1,t+1,&q);
    for(int i=1; s[i]; ++i)
        sp[i] = sp[i-1]+s[i]-'A'+1;
    for(int i=1; t[i]; ++i)
        tp[i] = tp[i-1]+t[i]-'A'+1;
    while(q--)
    {
        scanf("%d%d%d%d",&a,&b,&c,&d);
        if((sp[b]-sp[a-1])%3 == (tp[d]-tp[c-1])%3)
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值