HDU5317:RGCDQ (数学 & 二分)

Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  maxGCD(F(i),F(j)) maxGCD(F(i),F(j))  (Li<jR) (L≤i<j≤R)
Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries. 
In the next T lines, each line contains L, R which is mentioned above. 

All input items are integers. 
1<= T <= 1000000 
2<=L < R<=1000000 
Output
For each query,output the answer in a single line. 
See the sample for more details. 
Sample Input
2
2 3
3 5
Sample Output
1
1


题意:f[i]表示i的不同质因子数。T个询问,输出区间内gcd(f[i],f[j])最大的值。

思路:1e6范围内质因子至多7个不同,打个表对每个数的质因子数存下,二分查找即可。或者用前缀和也可以。

# include <iostream>
# include <cstdio>
# include <set>
# include <algorithm>
using namespace std;
const int N = 1e6+30;
int isprime[N+3], pcnt, cnt[N+3];
vector<int>v[10];
int main()
{
    int t, l, r;
    for(int i=2; i<N; ++i)
    {
        if(!isprime[i])
        {
            for(int j=i; j<N; j+=i)
            {
                isprime[j] = 1;
                ++cnt[j];
            }
        }
    }
    for(int i=2; i<=N-30; ++i)
        v[cnt[i]].push_back(i);
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%d%d",&l,&r);
            int i;
            for(i=8; i>=1; --i)
            {
                int p1 = upper_bound(v[i].begin(), v[i].end(), r)-v[i].begin()-1;
                int p2 = lower_bound(v[i].begin(), v[i].end(), l)-v[i].begin();
                if(p1-p2+1 >= 2)
                {
                    printf("%d\n",i);
                    break;
                }
            }
            if(i==0) puts("1");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值