1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

该题意思是多项式相加,前一个代表X的幂次,后一个代表系数项。

要考虑两项之和为0的情况,为零时删除对应项。

	#include <stdio.h>
	#include <stdlib.h>
	struct {
		int x;
		double y;
	} a[10];
	int main() {
		int i, j, n1, n2, t1, sum = 0;
		double t2;
		scanf("%d", &n1);
		for (i = 1; i <= n1; i++)
			scanf("%d%lf", &a[i].x, &a[i].y);
		scanf("%d", &n2);
		for (i = n1 + 1; i <= n1 + n2; i++)
			scanf("%d%lf", &a[i].x, &a[i].y);
		for (i = 1; i <= n1 + n2; i++) {
			for (j = i + 1; j <= n1 + n2; j++) {
				if (a[i].x == a[j].x) {
					a[j].x = -1;
					a[i].y += a[j].y;
					if (a[i].y == 0) {
						a[i].x = -1;
					}
				}
			}
		}
		for (i = 1; i <= n1 + n2; i++) {
			if (a[i].x != -1) {
				sum++;
			}
		}
		printf("%d", sum);
		for (i = 1; i <= n1 + n2 - 1; i++) {
			for (j = i + 1; j <= n1 + n2; j++) {
				if (a[i].x != -1 && a[j].x != -1) {
					if (a[i].x < a[j].x) {
						t1 = a[i].x;
						a[i].x = a[j].x;
						a[j].x = t1;
						t2 = a[i].y;
						a[i].y = a[j].y;
						a[j].y = t2;
					}
				}
			}
		}
		for (i = 1; i <= n1 + n2; i++) {
			if (a[i].x != -1) {
				printf(" %d %.1lf", a[i].x, a[i].y);
			}
		}
		printf("\n");
		return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值