1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None
#include <iostream>
#include <vector>
using namespace std;
vector<vector<int> > b;

int main() {
	int n, a[100001], f;
	b.clear();
	b.resize(100001);
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin>>a[i];
		b[a[i]].push_back(a[i]);
	}
	f = 0;
	for (int i = 0; i < n; i++) {
		if (b[a[i]].size() == 1) {
			f = 1;
			cout << b[a[i]][0] << endl;
			break;
		}
	}
	if (f == 0)
		cout << "None" << endl;
	return 0;
}

 vector函数:

 需要头文件:#include <vector>

定义类型 :vector<vector<类型> >名字a

a.clear() 清零vector

a.resize(长度) 定义a的大小

a[i].push_back(x) 将x放入vector a[i]中的首位

a[i][n] 指的是放在vector a[i]的第n个位置的值

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值