系统会随机给你一个日期(yyyy-MM-dd)字符串,你需要计算这个时间上一个月的最后一天的具体日期,最后以yyyy年MM月dd日的字符形式返回

试题描述

系统会随机给你一个日期(yyyy-MM-dd)字符串,你需要计算这个时间上一个月的最后一天的具体日期,最后以yyyy年MM月dd日的字符形式返回

输入

输入日期(格式为yyyy-MM-dd)的字符串

输出

输出结果 上一个月最后一天的日期(格式为yyyy年MM月dd日)

输入示例

2016-08-09

输出示例

20160731

思路

  • 本题考的是java日期处理,学一下应该没什么难度
package com.vapy.offer;

import java.text.SimpleDateFormat;
import java.util.Calendar;
import java.util.Scanner;

/**
 * 
 * @author vapy 2016年10月6日
 * 
 */
public class Main10 {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        String input = "";
        if (sc.hasNext()) {
            input = sc.next();
        }
        String[] str = input.split("-");
        int[] intInput = new int[str.length];
        for (int i = 0, len = str.length; i < len; i++) {
            intInput[i] = Integer.valueOf(str[i]);
        }

        SimpleDateFormat format = new SimpleDateFormat("yyyy年MM月dd日");
        Calendar c = Calendar.getInstance();
        c.set(intInput[0], intInput[1] - 1, intInput[2]);
        c.add(Calendar.MONTH, -1);
        c.set(Calendar.DAY_OF_MONTH, c.getActualMaximum(Calendar.DAY_OF_MONTH));
        String first = format.format(c.getTime());
        System.out.println(first);
    }
}

本文代码可在github查看:点击此处

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值