POJ 2259 Team Queue

Team Queue
   
   

Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue.

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements. 
Finally, a list of commands follows. There are three different kinds of commands: 
  • ENQUEUE x - enter element x into the team queue 
  • DEQUEUE - process the first element and remove it from the queue 
  • STOP - end of test case

The input will be terminated by a value of 0 for t. 
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one. 

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

问题:队列的模拟...就是给几组数据...插入队列...但是如果前面有同一组的数据的话要直接排到同组数据之后...

分析:精髓是用了一个主队列存储已经入队的元素组号...然后另n个队列则用来储存进队的元素...在我还在苦恼怎么实现是发现

大神用了映射的方法实现了队列名和队中元素的对应关系...QAQ...

#include<iostream>
#include<cstdio>
#include<queue>
#include<string>
using namespace std;
int n,case_number=1;
int member[1000010];//用来做映射的数组...数组编号是压入的数据...而对应的值则是组号...
bool haveit[1005];//用来判断是否是第一个元素进了主队列...
queue<int> main_q;//主队列
queue<int> minor_q[1005];//各个组

int init(){
	for(int i=0;i<n;i++){ //初始化
		haveit[i]=false;
		while(!minor_q[i].empty()){
			minor_q[i].pop();
		}
	}
	while(!main_q.empty()){
		main_q.pop();
	}
}
int input(){
	int q,ti;
	for(int i=0;i<n;i++){
		scanf("%d",&q);//输入元素
		while(q--){
			scanf("%d",&ti);
			member[ti]=i;//这里就是呢个映射的用法...好精妙的说
		}
	}
}
int solve(){
	string command;
	int t;
	printf("Scenario #%d\n",case_number++);
	while(cin>>command && command != "STOP"){
		
		if(command=="ENQUEUE"){
			cin>>t;
			if(!haveit[member[t]]){ //看这个元素是不是他所在呢组的队首... 
				main_q.push(member[t]);
				haveit[member[t]]=true; //映射关系绕来绕去...
			}
			minor_q[member[t]].push(t);
		}
		else if(command=="DEQUEUE"){
			int temp=main_q.front();
			printf("%d\n",minor_q[temp].front());
			minor_q[temp].pop();
			if(minor_q[temp].empty()){  //判断是否一组的元素出完了
				haveit[temp]=false;
				main_q.pop();
			}
		}
	}
	cout<<endl;
}
int main(){
	while(scanf("%d",&n) !=EOF &&n){
		init();
		input();
		solve();
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值