POJ 2036 Wireless Network

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

问题: 修电脑...两个电脑之间可以通讯...但有距离限制...修好一个电脑这个电脑就能和它附近的修好的电脑通讯...目标就是问你两个电脑之间能否通讯时给出
回答
分析:用并查集实现...简直好用...再用上路径压缩本来4000ms用完3000ms,不知道为什么这个代码在C++下会CE,用G++就好了,

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
using namespace std;
struct T{
	int x;
	int y;
	bool ok;
} point[1005]; //存放每个计算机的坐标位置 
 
int pre[1005];//存放每个计算机的父节点 

int find(int x){ //查找计算机根节点 
	int r=x;
	while(pre[r]!=r)
		r=pre[r];
	 int i=x , j ;
    while( i != r )    //路径压缩
    {
         j = pre[ i ]; //  在改变上级之前用临时变量  j 记录下他的值 
         pre[ i ]= r ; // 把上级改为根节点
         i=j;
    }
	return r;
}


double dis(int x1,int y1,int x2,int y2){ //两计算机之间距离 
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}

int init(int n){
	memset(pre,0,1005*sizeof(pre[0])); //初试化为每个计算机的根节点都是自己 
	for(int i=1;i<=n;i++)
		pre[i]=i;
}
int join(int x,int y,int distance){ //把两个计算机连接起来 
	int rx=find(x);
	int ry=find(y);
	if(rx!=ry){
		if(dis(point[x].x,point[x].y,point[y].x,point[y].y)<=distance)
			pre[rx]=ry;
	}
}
int main(){
	int n,distance;
//	freopen("3.txt","r",stdin);
	scanf("%d%d",&n,&distance);
	for(int i=1;i<=n;i++){
		scanf("%d%d",&point[i].x,&point[i].y);
		//cin>>point[i].x>>point[i].y;
	}
	init(n);
	char a[20];
	while(scanf("%s",&a)!=EOF){
		if(a[0]=='O'){
			int num;
			scanf("%d",&num);
			//num=num-1;
			point[num].ok=true;
			for(int j=1;j<=n;j++){
				if(point[j].ok&&j!=num){
					join(j,num,distance);
				}
			}	
		}
		else if(a[0]=='S'){
			int p1,p2;
			scanf("%d%d",&p1,&p2);
			if(find(p1)==find(p2)){
				printf("SUCCESS\n");
			}
			else
				printf("FAIL\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值