HDU_1495非常可乐(BFS)

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
Sample Input
7 4 3
4 1 3
0 0 0
Sample Output
NO
3


分析:倒水问题...三个水桶,3!种状态 S->N S->M N->S N->M M->N M->S 六种 用BFS暴力模拟...搜题解的时候看到了有大神用数论方法推出来了...简直厉害;

#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
const int N=100+5;
using namespace std;

struct node{
	int a,b,s,t;
}st;

int a,b,s;
bool visit[N][N];
queue<node> q;

void init(){
	memset(visit,0,sizeof(visit));
	while(!q.empty()){
		q.pop();
	}
}

int bfs(){
	init();
	node init1={0,0,s,0};
	visit[init1.a][init1.b]=true;
	q.push(init1);
	while(!q.empty()){
		node head=q.front(),next;
		if(head.a==s/2&&head.s==s/2){
			return next.t;
		}
		if(head.s&&head.a!=a){   //s->a
			int temp=a-head.a;
			if(temp>head.s){
				next.a=head.s+head.a;
				next.s=0;		
			}
			else{
				next.a=a;
				next.s=head.s-temp;
			}
			next.b=head.b;
			next.t=head.t+1;
			if(!visit[next.a][next.b]){
				q.push(next);
				visit[next.a][next.b]=true;
			}
		}
		if(head.s&&head.b!=b){   //s->b
			int temp=b-head.b;
			if(temp>head.s){
				next.b=head.s+head.b;
				next.s=0;		
			}
			else{
				next.b=b;
				next.s=head.s-temp;
			}
			next.a=head.a;
			next.t=head.t+1;
			if(!visit[next.a][next.b]){
				q.push(next);
				visit[next.a][next.b]=true;
			}
		}
		if(head.a&&head.s!=s){ //a->s
			next.s=head.s+head.a;
			next.a=0;
			next.b=head.b;
			next.t=head.t+1;
			if(!visit[next.a][next.b]){
				q.push(next);
				visit[next.a][next.b]=true;
			}
		}
		if(head.a&&head.s!=s){ //a->b
			int temp=b-head.b;
			if(temp>head.a){
				next.b=head.b+head.a;
				next.a=0;
			}
			else{
				next.b=b;
				next.a=head.a-temp;
			}
			next.s=head.s;
			next.t=head.t+1;
			if(!visit[next.a][next.b]){
				q.push(next);
				visit[next.a][next.b]=true;
			}
		}
		if(head.b&&head.s!=s){ //b->s
			next.s=head.s+head.b;
			next.b=0;
			next.a=head.a;
			next.t=head.t+1;
			if(!visit[next.a][next.b]){
				q.push(next);
				visit[next.a][next.b]=true;
			}
		}
		if(head.b&&head.s!=s){ //b->a
			int temp=a-head.a;
			if(temp>head.b){
				next.a=head.b+head.a;
				next.b=0;
			}
			else{
				next.a=a;
				next.b=head.b-temp;
			}
			next.s=head.s;
			next.t=head.t+1;
			if(!visit[next.a][next.b]){
				q.push(next);
				visit[next.a][next.b]=true;
			}
		}
		q.pop();
	}
	return 0;
}

int main(){
	while(scanf("%d%d%d",&s,&a,&b),s||a||b){
		if(s%2){
			printf("NO\n");
			continue;
		}
		if(a<b) swap(a,b);
		int ans=bfs();
		if(ans) printf("%d\n",ans);
		else printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值