HDU 3172 (STL map)

Virtual Friends

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4665    Accepted Submission(s): 1320


Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

Input
Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input
  
  
1 3 Fred Barney Barney Betty Betty Wilma

Sample Output
  
  
2 3 4

与上篇我写的并查集差不多,只是这里需要用到map容器了,学习到了map容器中 .find() 的用法,↖(^ω^)↗

#include<cstdio>
#include<string>
#include<map>
using namespace std;

const int num = 100001;
int p[num], sum[num];
char s1[num][21], s2[num][21];

int find(int x) {return p[x] == x ? x : p[x] = find(p[x]);}

int main()
{
    int T, n, i;

    while(~scanf("%d", &T))
    {
        while(T--)
        {
            scanf("%d", &n);
            for(i=1; i<=num; i++) p[i] = i, sum[i] = 1;
            map<string,int> m;
            int g = 1; //人物个数
            for(i=1; i<=n; i++)
            {
                scanf("%s%s", s1[i],s2[i]);
                if(m.find(s1[i]) == m.end())  //说明:遍历整个map容器,判断键值x是否在map中存在。
                    m[s1[i]] = g++;           //参数:x。待搜索的键值,注意,其实是指针!
                if(m.find(s2[i]) == m.end())  //返回:成功返回指向键值为x的元素的迭代器,失败返回map.end().
                    m[s2[i]] = g++;
                int x = find(m[s1[i]]);
                int y = find(m[s2[i]]);
                if(x != y)
                {
                    p[x] = y;
                    sum[y] += sum[x];
                }
                printf("%d\n", sum[y]);
            }
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值