Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 26990 Accepted Submission(s): 12042
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
Source
经典的素数环问题,利用回溯法。
#include<stdio.h>
#include<string.h>
int n, A[30], vis[30], isp[200];
void dfs(int cur) //cur代表第几个环
{
int i;
if(cur == n && isp[A[0]+A[n-1]] == 0) //到达最后时只要验证一下即可输出
{
for(i=0; i<n; i++)
printf(i == 0 ? "%d" : " %d", A[i],A[i]);
printf("\n");
}
else for(i=2; i<=n; i++) //枚举每个环可能放的数
{
if(!vis[i] && isp[i+A[cur-1]] == 0) //如果i没用过并且与前一个和为素数
{
A[cur] = i; //A数组代表第cur个环的数
vis[i] = 1; //表示已经用了
dfs(cur+1); //继续搜索下一个
vis[i] = 0; //清除标志!(如果能一直合法递归下去,则在上面已经输出
} //如果不能,则此数字就应清除标记重新选出下一个数字
}
}
int main()
{
int i, j, Case = 1;
memset(isp, 0, sizeof(isp));
for(int i=2; i<120; i++) //生成素数表
{
if(isp[i] == 0)
for(j=i+i; j<120; j+=i)
isp[j] = -1;
}
while(~scanf("%d", &n))
{
printf("Case %d:\n", Case++);
memset(vis, 0, sizeof(vis));
A[0] = 1; //每次第一个都是1
dfs(1);
printf("\n");
}
return 0;
}