Prime Ring Problem (HDU 1016)—— 回溯法

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26990    Accepted Submission(s): 12042


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
  
  
6 8

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

Source

 

经典的素数环问题,利用回溯法。

#include<stdio.h>
#include<string.h>
int n, A[30], vis[30], isp[200];

void dfs(int cur) //cur代表第几个环
{
    int i;
    if(cur == n && isp[A[0]+A[n-1]] == 0) //到达最后时只要验证一下即可输出
    {
        for(i=0; i<n; i++)
            printf(i == 0 ? "%d" : " %d", A[i],A[i]);
        printf("\n");
    }
    else for(i=2; i<=n; i++) //枚举每个环可能放的数
    {
        if(!vis[i] && isp[i+A[cur-1]] == 0) //如果i没用过并且与前一个和为素数
        {
            A[cur] = i; //A数组代表第cur个环的数
            vis[i] = 1; //表示已经用了
            dfs(cur+1); //继续搜索下一个
            vis[i] = 0; //清除标志!(如果能一直合法递归下去,则在上面已经输出
        }               //如果不能,则此数字就应清除标记重新选出下一个数字
    }
}

int main()
{
    int i, j, Case = 1;

    memset(isp, 0, sizeof(isp));
    for(int i=2; i<120; i++) //生成素数表
    {
        if(isp[i] == 0)
            for(j=i+i; j<120; j+=i)
                isp[j] = -1;
    }
    while(~scanf("%d", &n))
    {
        printf("Case %d:\n", Case++);
        memset(vis, 0, sizeof(vis));
        A[0] = 1; //每次第一个都是1
        dfs(1);
        printf("\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值