HDU 1531(差分约束)

King

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1158    Accepted Submission(s): 526


Problem Description
Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.
 

Input
The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.
 

Output
The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.
 

Sample Input
  
  
4 2 1 2 gt 0 2 2 lt 2 1 2 1 0 gt 0 1 0 lt 0 0
 

Sample Output
  
  
lamentable kingdom successful conspiracy
 

Source
 

题意:
看了n遍才看懂题目。。首先给你两个数n和m,n表示一个长度为n的序列,m表示接下来有m个约束条件。接下来每行有一个约束条件,包含数据si,ni,oi,ki。si表示这个序列中的其中一个元素的序号,ni表示那个元素后面连续的ni个元素,oi等于"gt" 或 ”lt","gt" 表示 '>' ,"lt" 表示 '<' ,也就是说约束条件为A(si)+A(si+1)+...A(si+ni) oi ki (si+ni为A序列的序号)。

分析:
想了很久一直没有思路,虽然我知道应该是差分约束。。后来看别人的才发现自己对差分约束理解限制的太死板了。差分约束就是找到题目给你的一些约束条件以及一些隐含条件来利用最短路求解。而现在它每个约束条件有ni+1个元素,比如:2 2 lt 0,就是说a2+a3+a4 < 0,最短路不是两点连成一条边么。。现在含有3个元素,我改怎么取点连边呢。。苦思冥想啊。。最后才知道自己2了一下。。。其实约束条件可以写成Sum[si+ni+1]-Sum[si] oi ki...(Sum[si]表示1 ~ si-1这si-1个元素的和)也就是说两个元素,一头一尾相减就是其中的加和了。我以为一定要实际的数据,其实虚拟的东西也可以,比如这题加进去的两个点就表示一段序列的和。。注意这题是 '>' 和 '<' 要把它转换成 ‘>=' 和 '<=' 的形式,因为这是求最短路的条件。。

code:
#include<stdio.h>
int cnt, n, m, d[110];
struct Edge
{
    int from, to, cost;
}e[110];

void add(int u, int v, int w)
{
    e[cnt].from = u;
    e[cnt].to = v;
    e[cnt++].cost = w;
}

int Bellman_Ford()
{
    for(int i=0; i<110; i++) d[i] = -1e8;
    bool update;
    for(int j=1; j<=n+5; j++)
    {
        update = false;
        for(int i=0; i<cnt; i++)
        {//用的是最长路求
            if(d[e[i].from]+e[i].cost > d[e[i].to])
            {
                d[e[i].to] = d[e[i].from]+e[i].cost;
                update = true;
            }
        }
        if(!update) break;
    }
    if(update) return 0;
    return 1;
}

int main()
{
    int m, si, ni, ki;
    char oi[5];

    while(scanf("%d", &n),n)
    {
        scanf("%d", &m);
        cnt = 0;
        while(m--)
        {
            scanf("%d%d%s%d", &si,&ni,oi,&ki);
            if(oi[0] == 'g') add(si,si+ni+1,ki+1);
            else add(ni+si+1,si,-ki+1);
        }
        if(Bellman_Ford()) puts("lamentable kingdom");
        else puts("successful conspiracy");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值